Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive a "Could not connect EDI Subsystem (StartDatabase returned -2) to Database" error message, and the BizTalk Base EDI service does not start in BizTalk Server 2004


View products that this article applies to.

Symptoms

In Microsoft BizTalk Server 2004, when you try to start the BizTalk Base Electronic Data Interchange (EDI) service, you receive an error message that is similar to the following in the Application log:
Could not connect EDI Subsystem (StartDatabase returned -2) to Database
Additionally, the BizTalk Base EDI service does not start.

↑ Back to the top


Cause

This problem occurs if the following conditions are true:
The BizTalk Base EDI database is on a remote computer that is running Microsoft SQL Server 2000.
The SQL Server client tools are not installed on the computer that is running the BizTalk Base EDI service.

↑ Back to the top


Resolution

To resolve this problem, install the SQL Server client tools on the computer that is running the BizTalk Base EDI service. After you install the SQL Server client tools, you can successfully start the BizTalk Base EDI service.

Note The SQL Server client tools are located on the SQL Server 2000 installation CD.

↑ Back to the top


More information

For more information about BizTalk Server 2004 deployment, visit the following Microsoft Developer Network (MSDN) Web site:

↑ Back to the top


Keywords: KB901267, kbprb, kbtshoot, kbinfo, kbstartup, kbservice

↑ Back to the top

Article Info
Article ID : 901267
Revision : 2
Created on : 3/15/2007
Published on : 3/15/2007
Exists online : False
Views : 392