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A Terminal Services client computer may make beep sounds after you connect to a Windows Server 2003 Service Pack 1-based computer


View products that this article applies to.

Symptoms

After you connect to a Microsoft Windows Server 2003 Service Pack 1-based computer through a Terminal Services session, the Terminal Services client computer may make a beep sound when certain events occur.

For example, this problem occurs when you start Notepad on a Terminal Services client computer, type some characters, and then close Notepad without saving the changes. A message box prompts you to save the changes that you made. The message box opens with a beep sound.

Note You experience these symptoms after you install Windows Server 2003 Service Pack 1 on a Terminal Server.

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Cause

This issue occurs because the MessageBeep function is redirected to the Terminal Services client computer. If the Terminal Services client computer does not support audio, the beep sound is played through the system speaker.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003, x86-based versions

   Date         Time   Version            Size    File name
--------------------------------------------------------------
11-Jun-2005 03:02 5.2.3790.346 988,672 Kernel32.dll
11-Jun-2005 03:02 5.2.3790.346 222,208 Termsrv.dll
11-Jun-2005 03:02 5.2.3790.346 52,224 Winsta.dll
25-Feb-2005 03:51 6.1.22.4 371,936 Updspapi.dll

Windows Server 2003 with Service Pack 1, x86-based versions

   Date         Time   Version            Size    File name 
--------------------------------------------------------------------
30-Jun-2005 02:35 5.2.3790.360 988,672 Kernel32.dll
30-Jun-2005 02:35 5.2.3790.360 222,208 Termsrv.dll
30-Jun-2005 02:35 5.2.3790.360 52,224 Winsta.dll
05-Mar-2005 01:30 6.1.22.4 371,936 Updspapi.dll
30-Jun-2005 03:06 5.2.3790.2477 245,248 Termsrv.dll
30-Jun-2005 00:58 5.2.3790.2477 32,256 Arpidfix.exe

Windows Server 2003, Itanium-based versions

    Date         Time   Version            Size    File name       Platform
--------------------------------------------------------------------
10-Jun-2005 14:29 5.2.3790.346 1,851,392 Kernel32.dll IA-64
10-Jun-2005 14:29 5.2.3790.346 621,568 Termsrv.dll IA-64
10-Jun-2005 14:29 5.2.3790.346 141,824 Winsta.dll IA-64
10-Jun-2005 14:32 5.2.3790.346 934,912 Wkernel32.dll x86
10-Jun-2005 14:32 5.2.3790.346 52,224 Wwinsta.dll x86
24-Feb-2005 15:22 6.1.22.4 639,712 Updspapi.dll IA-64

Windows Server 2003 with Service Pack 1, Itanium-based versions

   Date         Time   Version            Size    File name         Platform
-----------------------------------------------------------------------
29-Jun-2005 15:02 5.2.3790.360 1,851,392 Kernel32.dll IA-64
29-Jun-2005 15:02 5.2.3790.360 621,568 Termsrv.dll IA-64
29-Jun-2005 15:02 5.2.3790.360 141,824 Winsta.dll IA-64
29-Jun-2005 15:02 5.2.3790.360 934,912 Wkernel32.dll x86
29-Jun-2005 15:02 5.2.3790.360 52,224 Wwinsta.dll x86
29-Jun-2005 15:02 5.2.3790.2477 696,320 Termsrv.dll IA-64
29-Jun-2005 15:02 5.2.3790.2477 74,752 Arpidfix.exe IA-64
29-Jun-2005 15:02 6.1.22.4 639,712 Updspapi.dll IA-64

Windows Server 2003, x64-based versions

   Date         Time   Version            Size    File name
--------------------------------------------------------------
29-Jun-2005 15:02 5.2.3790.2477 363,008 Termsrv.dll
29-Jun-2005 15:02 5.2.3790.2477 43,008 Arpidfix.exe
29-Jun-2005 15:02 6.1.22.4 462,560 Updspapi.dll

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More Information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows


After you apply the hotfix, you can use the registry to enable redirection of the MessageBeep function. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type DisableBeep, and then press ENTER.
  5. Right-click DisableBeep, and then click Modify.
  6. In the Value data box, type 0, and then click OK.

    Note You can disable the MessageBeep function by changing the value to 1.
  7. Quit Registry Editor.
For more information about the description of the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kb, kbautohotfix, kbwinserv2003sp2fix, kbhotfixserver, kbentirenet, kbbug, kbfix, kbqfe, kbpubtypekc

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Article Info
Article ID : 901115
Revision : 3
Created on : 3/30/2017
Published on : 3/30/2017
Exists online : False
Views : 253