Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"ESENT" and "Groveler" events are logged in the Application log when you use the Remote Installation Services component in Windows Server 2003


View products that this article applies to.

Symptoms

Consider the following scenario:
  • The Remote Installation Services (RIS) component is installed on a Microsoft Windows Server 2003-based computer.
  • You try to use the RIS volume on the Windows Server 2003-based computer to store CD-ROM-based images or Remote Installation Preparation (RIPrep) images.
In this scenario, the following events are logged in the Application log:

Event Type: Error Event Source: ESENT Event Category: Transaction Manager Event ID: 623 User: N/A Computer: Computer_name Description: grovel (1344). The version store for this instance (0) has reached its maximum size of 2Mb. It is likely that a long-running transaction is preventing cleanup of the version store and causing it to build up in size. Updates will be rejected until the long-running transaction has been completely committed or rolled back. Possible long-running transaction: SessionId: 0x03390280 Session-context: 0x00000000 Session-context ThreadId: 0x00000558 Event Type: Error Event Source: Groveler Event Category: None Event ID: 12292 User: N/A Computer: Computer_name Description: The groveler on partition d:\ has failed due to a database error. See ESENT event log entries for details.

↑ Back to the top


Cause

This issue occurs because the RIS Groveler service tries to perform cleanup work on a transaction that is too large to process. The hotfix that is described in the "Resolution" section breaks up the single large transaction into several smaller transactions.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any oth er hotfixes. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, Itanium-based versions
	
      Date         Time   Version            Size    File name
   --------------------------------------------------------------
   26-May-2005  01:57  5.2.3790.337      220,672  Grovel.exe       IA-64
   26-May-2005  01:57  5.2.3790.337      210,944  Sis.sys

Windows Server 2003, Itanium-based versions with Service Pack 1
	
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   26-May-2005  01:57  5.2.3790.2453     243,712  Grovel.exe       IA-64

Windows Server 2003, x64-based versions with Service Pack 1
	
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   26-May-2005  01:57  5.2.3790.2453     143,872  Grovel.exe       

Windows Server 2003, x86-based versions
	
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   26-May-2005  00:10  5.2.3790.337       78,336  Grovel.exe       
   26-May-2005  00:10  5.2.3790.337       66,048  Sis.sys

Windows Server 2003, x86-based versions with Service Pack 1
	
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   26-May-2005  00:51  5.2.3790.2453      81,920  Grovel.exe       

↑ Back to the top


Status

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.
This problem was first corrected in Windows Server 2003 Service Pack 2.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: KB900617, kbqfe, kbHotfixServer, kbbug, kberrmsg, kbautohotfix

↑ Back to the top

Article Info
Article ID : 900617
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 367