Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The W3wp.exe process consumes up to 99 percent of the CPU resources every several minutes on a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

On a computer that is running Microsoft Windows Server 2003, the W3wp.exe process consumes up to 99 percent of the CPU resources every several minutes. This problem occurs if the following conditions are true:
  • Microsoft Exchange Server 2003 is running on the computer.
  • Microsoft Outlook Web Access (OWA) is installed on the computer.
  • The Front-end server only option is enabled in Exchange Server 2003.

↑ Back to the top


Cause

This problem occurs because of an incorrect algorithm in the Wldap32.dll module. This incorrect algorithm copies the memory too frequently. This behavior causes a performance problem.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Wldap32.dll5.2.3790.340162,81601-Jun-200502:20x86NoneRTMQFE
Wldap32.dll5.2.3790.2456178,68801-Jun-200502:34x86SP1SP1QFE
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Wldap32.dll5.2.3790.340427,00831-May-200512:11IA-64NoneRTMQFE
Wwldap32.dll5.2.3790.340162,81631-May-200512:11x86NoneWOW
Wldap32.dll5.2.3790.2456453,63231-May-200512:11IA-64SP1SP1QFE
Wwldap32.dll5.2.3790.2456178,68831-May-200512:11x86SP1WOW
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Wldap32.dll5.2.3790.2456399,87231-May-200512:11x64SP1SP1QFE
Wwldap32.dll5.2.3790.2456178,68831-May-200512:11x86SP1WOW

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbwinserv2003sp2fix, kbwinserv2003presp2fix, kbexpertiseinter, kbbug, kbfix, kbqfe, KB900243

↑ Back to the top

Article Info
Article ID : 900243
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 293