Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: A Component Services application package may stop responding in Host Integration Server 2004 on Windows Server 2003


View products that this article applies to.

Symptoms

A Component Services application package may stop responding if the following conditions are true:
The Transaction Integrator (TI) Windows Initiated Processing (WIP) COM object in Microsoft Host Integration Server 2004 is running on a computer that is running Microsoft Windows Server 2003.
The TI WIP COM object is installed in the same Component Services application package as the client program that is accessing the TI WIP COM object.

Note The client program in this case is a custom DLL that is written to call methods that are exposed by the TI WIP COM object.

↑ Back to the top


Cause

This problem occurs when the client program makes a CreateObject function call on the TI WIP COM object. The TI Runtime then makes a Windows API call that blocks the threads in the Component Services application package Dllhost.exe process. Because these threads are blocked, the Component Services application package stops responding.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is now available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem, submit a request to Microsoft Online Customer Services to obtain the hotfix. To submit an online request to obtain the hotfix, visit the following Microsoft Web site:Note If additional issues occur or any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. To create a separate service request, visit the following Microsoft Web site:

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   ---------------------------------------------------------------------------------------
   27-May-2005  18:14  6.0.1955.0   25,600  Capture.dll
   27-May-2005  18:14  6.0.1955.0   98,816  Dcgen.dll
   27-May-2005  18:14  6.0.1701.0    4,096  Microsoft.hostintegration.ti.dcgen.interop.dll
   27-May-2005  18:14  6.0.1955.0  249,344  Mobase.dll
   27-May-2005  18:14  6.0.1955.0   24,064  Playback.dll
   27-May-2005  18:14  6.0.1955.0   94,720  Tagen.dll
   27-May-2005  18:14  6.0.1955.0   34,304  Turnaround.dll
Note Because of file dependencies, the most recent hotfix that contains these files may contain additional files.

↑ Back to the top


Workaround

To work around this problem, install the client program that makes the CreateObject function call on the TI WIP COM object in a separate Component Services application package from the TI type library.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: KB899810, kbhis2004, kbhotfixserver, kbpubtypekc, kbqfe, kbfix, kbbug

↑ Back to the top

Article Info
Article ID : 899810
Revision : 5
Created on : 12/4/2007
Published on : 12/4/2007
Exists online : False
Views : 336