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Windows Firewall may drop ICMP packets in Windows Server 2003 with Service Pack 1 (SP1)


View products that this article applies to.

Symptoms

On a computer that is running Microsoft Windows Server 2003 with Service Pack 1 (SP1), Windows Firewall may drop Internet Control Message Protocol (ICMP) packets, even though ICMP is enabled in the firewall configuration. For example, this problem may occur on a multihomed computer under the following conditions:
  • The computer receives an ICMP echo request on the NIC1 network adaptor.
  • The IP destination of the packet is the IP address of the NIC2 network adaptor.
When this problem occurs, information that is similar to the following appears in the firewall log:
2005-04-12 11:45:50 DROP ICMP 169.168.25.1 10.10.1.1 - - 60 - - - - 0 0 - SEND

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Cause

This problem occurs because an anti-spoofing rule drops packets whose source IP address is bound to a different adaptor than the adaptor to which the ICMP packets are sent.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Microsoft Windows Server 2003, 32-bit versions
   Date         Time   Version        Size     File name
   -----------------------------------------------------
   14-May-2005  00:35  5.2.3790.2444  102,912  Ipnat.sys
Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
   Date         Time   Version        Size     File name
   -----------------------------------------------------
   16-May-2005  01:42  5.2.3790.2444  349,696  Ipnat.sys
Microsoft Windows Server 2003, x64-based versions
   Date         Time   Version        Size     File name
   -----------------------------------------------------
   16-May-2005  01:42  5.2.3790.2444  155,648  Ipnat.sys

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbbug, kbfix, kbhotfixserver, kbqfe, KB899657

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Article Info
Article ID : 899657
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 268