Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Not all processors on some multiprocessor computers are recognized by x64-based versions of Windows Server 2003


View products that this article applies to.

Symptoms

On some multiprocessor computers, not all processors are recognized by x64-based versions of Microsoft Windows Server 2003.

↑ Back to the top


Cause

This problem occurs because of how some dual-core processor based computers implement Advanced Programmable Interrupt Controller (APIC) numbering in their ROM BIOS.

↑ Back to the top


Resolution

Update information

The following file is available for download from the Microsoft Download Center:
Download the 899656 package now. Release Date: August 16, 2005

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this update.

Update replacement information

This update does not replace any other updates.

File information

The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size  File name
   --------------------------------------------------------
   09-Jul-2005  04:53  5.2.3790.2484  279,040  Hal.dll
   09-Jul-2005  04:53  5.2.3790.2484   43,008  Arpidfix.exe

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site: For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: KB899656, kbqfe, kbwinserv2003sp2fix, atdownload

↑ Back to the top

Article Info
Article ID : 899656
Revision : 10
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 315