Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A BizTalk Server Host instance fails, and a "General Network" error is written to the Application log when the BizTalk Server-based server processes a high volume of documents


View products that this article applies to.

Symptoms

A Microsoft BizTalk Server Host instance fails and then restarts itself, and errors that are similar to the following are written to the BizTalk Server Application log:
Event Type: Error
Event Source: BizTalk Server 2004
Event Category: (1)
Event ID: 6913
Computer: BizTalkServer
Description: SQLServer, BizTalkMsgBoxDb, [DBNETLIB][ConnectionWrite (send()).]General network error. Check your network documentation..
Event Type: Warning
Event Source: BizTalk Server 2004
Event Category: (1)
Event ID: 5410
Computer: BizTalkServer
Description: An error has occurred that requires the BizTalk service to terminate. The most common causes are an unexpected out of memory error and an inability to connect or a loss of connectivity to one of the BizTalk databases. The service will shutdown and auto-restart in 1 minute. If the problematic database remains unavailable, this cycle will repeat.

Error message: [DBNETLIB][ConnectionWrite (send()).]General network error. Check your network documentation.

Error source:
BizTalk host name: BizTalkHost
BizTalk Windows service name: BTSSvc$BizTalkHost.
This issue typically occurs when the BizTalk Server-based server processes a high volume of documents.

↑ Back to the top


Cause

This issue occurs because Windows Server 2003 and later versions implement a security feature that reduces the size of the queue for concurrent TCP/IP connections to the server. This feature helps prevent denial of service attacks. Under heavy load conditions, the TCP/IP protocol may incorrectly identify a valid TCP/IP connections as a denial of service attack. This behavior may lead to the issue that is described in the "Symptoms" section.

↑ Back to the top


Resolution

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows


To resolve this issue, turn off this new functionality by adding the SynAttackProtect entry to the following registry key on the computer that is running Microsoft SQL Server that houses your BizTalk Server databases.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
Set the
SynAttackProtect
entry to a DWORD value of 00000000. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type SynAttackProtect, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. In the Value data box, type 00000000. Click OK.
  7. Quit Registry Editor.
Note To complete this registry change, you must restart the computer that is running SQL Server.

↑ Back to the top


Status

This behavior is by design.

↑ Back to the top


Keywords: kbprb, KB899599

↑ Back to the top

Article Info
Article ID : 899599
Revision : 9
Created on : 6/7/2007
Published on : 6/7/2007
Exists online : False
Views : 376