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You may receive an "Access is denied" error message you use the WWW-Authenticate: Negotiate method of HTTP authentication to connect to a Web server


View products that this article applies to.

Symptoms

When you use the WWW-Authenticate: Negotiate method of HTTP authentication to connect to a Web server, you may receive an error message that is similar to the following if the Internet Explorer client DNS cache entry expires:
HTTP Error 401 - Unauthorized: Access is denied

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Cause

This issue occurs if the following conditions are true:
  • The Internet Explorer advanced option Enable Integrated Windows Authentication is enabled.
  • You use the NetBIOS name to access the Web site, and the name is resolved through Domain Name System (DNS) as a fully qualified domain name (FQDN).
  • The Web site Service Principal Name (SPN) exists only as an FQDN in the Active Directory directory service.
  • The value for the DNS Cache Timeout setting is lower than the DNS Time to Live (TTL) setting value.
When you use the WWW-Authenticate: Negotiate method of HTTP authentication, the Internet Explorer client DNS cache entry may expire. When this entry expires, the Wininet.dll file on the client computer uses the Hostname entry in the Uniform Resource Identifier of the HTTP request to request a new SPNEGO token from the domain controller. The Wininet.dll file uses this Hostname entry instead of using the FQDN that was returned from the initial DNS Resolver query.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Internet Explorer 6 Service Pack 1 for Windows 98, Internet Explorer 6 Service Pack 1 for Windows Millennium Edition, Internet Explorer 6 Service Pack 1 for Windows 2000, and Internet Explorer 6 Service Pack 1 for Windows XP

   Date         Time   Version           Size     File name
   ----------------------------------------------------------
   10-Jun-2005  18:53  6.0.2800.1510     585,728  Wininet.dll   

Internet Explorer 6 for Windows XP Service Pack 2

   Date         Time   Version           Size     File name
   --------------------------------------------------------
   11-Jun-2005  02:42  6.0.2900.2696     659,456  Wininet.dll  

Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems and Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems

   Date         Time   Version         Size       File name    Platform
   ---------------------------------------------------------------------
   14-Jun-2005  03:15  6.0.3790.347    1,509,888  Wininet.dll   IA-64
   14-Jun-2005  03:15  6.0.3790.347      627,712  Wwininet.dll  x86   

x86-based versions of Windows Server 2003

   Date         Time   Version           Size     File name
   ----------------------------------------------------------
   14-Jun-2005  03:15  6.0.3790.347      627,712  Wininet.dll  

Windows Server 2003 Service Pack 1

   Date         Time   Version           Size     File name
   ----------------------------------------------------------
   14-Jun-2005  19:14  6.0.3790.2464     662,528  Wininet.dll

Windows XP

   Date         Time   Version           Size     File name
   ----------------------------------------------------------
   11-Jun-2005  02:42  6.0.2900.2696     659,456  Wininet.dll  

Internet Explorer 7 for Windows XP Service Pack 2

   Date         Time   Version           Size     File name
   ----------------------------------------------------------
   15-May-2008  15:40  7.0.6000.20833    827,904  Wininet.dll  

Internet Explorer 7 for Windows Server 2003

   Date         Time   Version           Size       File name    Platform
   ---------------------------------------------------------------------
   16-May-2008  10:38  7.0.6000.20833    827,904    Wininet.dll  x86
   16-May-2008  08:28  7.0.6000.20833    1,024,000  Wininet.dll  x64
   16-May-2008  08:25  7.0.6000.20833    1,887,744  Wininet.dll  IA-64   

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Workaround

To work around this problem and reduce the frequency of this error, set the Internet Explorer DNS Cache Timeout value to the same value as the DNS TTL value in the enterprise. To set the Internet Explorer DNS Cache Time-out value, follow these steps:
  1. Click Start, click Run, type Regedit, and then click OK.
  2. To set the Internet Explorer DNS Cache Timeout value per user, locate and then click the following registry subkey:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\Current Version\Internet Settings
  3. On the Edit menu, point to New, and then click DWORD value.
  4. Type DNSCacheTimeout and then press ENTER.
  5. Click DNSCacheTimeout, click Edit, and then click Modify.
  6. In the Value data box, type the value that you want in seconds, and then click OK.

    Note The default value for the DNS TTL is 1800 seconds.
  7. Quit Registry Editor.

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More information

To enable this hotfix, follow these steps:
  1. Click Start, click Run, type Regedit, and then click OK.
  2. To enable this hotfix per user, locate and then click the following registry subkey:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
    To enable this hotfix per computer, locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. On the Edit menu, point to New, and then click Key.
  4. Type FEATURE_ENSURE_FQDN_FOR_NEGOTIATE_KB899417 and then press ENTER.
  5. Click FEATURE_ENSURE_FQDN_FOR_NEGOTIATE_KB899417.
  6. On the Edit menu, point to New, and then click DWORD value.
  7. Type Iexplore.exe and then press ENTER.
  8. Click Iexplore.exe.
  9. On the Edit menu, click Modify.
  10. In the Value data box, type 1, and then click OK.

    Note The valid values for the Iexplore.exe subkey are 0 and 1. A value of 1 enables the hotfix. A value of 0 disables the hotfix.
  11. Click FEATURE_ENSURE_FQDN_FOR_NEGOTIATE_KB899417.
  12. On the Edit menu, point to New, and then click DWORD value.
  13. Type Explorer.exe and then press ENTER.
  14. Click Explorer.exe.
  15. On the Edit menu, click Modify.
  16. In the Value data box, type 1, and then click OK.

    Note The valid values for the Explorer.exe subkey are 0 and 1. A value of 1 enables the hotfix. A value of 0 disables the hotfix.
  17. Quit Registry Editor.
For more information about SPNEGO and authentication, visit the following Microsoft Web site:

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Status

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

This problem was first corrected in Windows Server 2003 Service Pack 2.

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Keywords: kbwinserv2003sp2fix, kbqfe, kbhotfixserver, kbauthentication, kbfix, kbbug, kbautohotfix, KB899417

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Article Info
Article ID : 899417
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 331