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You may receive a "Windows could not start due to an error while booting the RAMDISK" error when you try to start a Windows Server 2003-based computer into the Deployment Agent


View products that this article applies to.

Symptoms

You try to start a Microsoft Windows Server 2003-based computer into the Deployment Agent by using the Windows Server 2003 Automated Deployment Services (ADS). In this scenario, you may receive the following error message on the destination computer:
Windows could not start due to an error while booting the RAMDISK. Windows failed to build a bootable RAMDISK image. System will reboot in 5 seconds

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Cause

This problem may occur if the computer is using more than 32 PCI devices.

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Resolution

To resolve this problem, install this hotfix on the ADS server that is running the Deployment Agent Builder service.

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Windows Server 2003 Service Pack 1 (SP1)

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   12-May-2005  03:23  5.2.3790.2443     325,120  Osloader.ntd

Hotfix installation instructions

To install the hotfix, follow these steps:
  1. Double-click the hotfix installer package.

    The Osloader.ntd file is extracted to a temporary folder in the root folder of %systemdrive%. For example, the Osloader.ntd file is extracted to a folder location that is similar to the following:
    c:\7d3c7dedd1efd4be3c41b1b4a180\Osloader.ntd
    Note The name of the temporary folder may vary.
  2. In Windows Explorer, locate the following folder:
    %systemdrive%\Program Files\Microsoft ADS\tftproot\nbs\boot\x86
    Note The %systemdrive% environmental variable specifies the drive letter of the drive that contains Windows. By default, this is drive C.
  3. In the x86 folder, rename the Ntldr file to Ntldrold.
  4. Copy the Osloader.ntd file from the temporary folder to the %systemdrive%\Program Files\Microsoft ADS\tftproot\nbs\boot\x86 folder.
  5. Rename the Osloader.ntd file to Ntldr.
  6. Restart the ADS services.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB899343, kbhotfixserver, kbqfe, kberrmsg, kbwinserv2003sp2fix, kbautohotfix

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Article Info
Article ID : 899343
Revision : 8
Created on : 3/28/2007
Published on : 3/28/2007
Exists online : False
Views : 189