Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Internet Explorer 6 stops responding, and you receive an access violation error message when you try to view a Web page that contains a .jpeg file


View products that this article applies to.

Symptoms

When you try to view a Web page that contains a .jpeg file, Microsoft Internet Explorer 6 stops responding. Additionally, you receive an error message that is similar to the following:
Unhandled exception at 0x7d708910 in iexplore.exe: 0xC0000005: Access violation writing location 0x0000006c.
An event ID that is similar to the following event ID may also be logged in the Application log:

Event ID: 1000
Source: Application Error
Description: Faulting Application: Iexplore.exe Version: 6.0.2900.2180
Faulting Module: Mshtml.dll Version 6.0.2900.2627
Faulting Address: 0x00268910

↑ Back to the top


Cause

This problem occurs when the Web site contains a malformed .jpeg file that has the wrong values for the number of scan lines. This causes the Mshtml.dll file to access a null pointer when the .jpeg file is rendered.

↑ Back to the top


Resolution

Microsoft Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003 Service Pack 1

Date        Time   Version        Size       File name
-------------------------------------------------------
09-Jun-2005 18:43  6.0.3790.2461  3,109,376  Mshtml.dll

Windows Server 2003

Date        Time   Version       Size        File name
-------------------------------------------------------
08-Jun-2005 18:26  6.0.3790.343  2,932,224   Mshtml.dll

Microsoft Windows XP Service Pack 2

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date 	    Time   Version        Size       File name
-------------------------------------------------------
09-Jun-2005 02:40  6.0.2900.2694  3,015,168  Mshtml.dll

Hotfix information for Internet Explorer 6 Service Pack 1

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date        Time   Version        Size       File name
-------------------------------------------------------
09-Jun-2005 22:10  6.0.2800.1510  2,704,896  Mshtml.dll

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

↑ Back to the top


Keywords: KB899102, kbbug, kbfix, kbie600fix, kbhotfixserver, kbqfe, kbwinserv2003presp2fix, kbautohotfix

↑ Back to the top

Article Info
Article ID : 899102
Revision : 4
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 246