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The MFC-based application that runs on the original release version of Windows Server 2003 leaks file handles when it opens files from a Samba share location


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a Microsoft Foundation Classes (MFC)-based application that runs on the original release version of Microsoft Windows Server 2003.
  • This application opens files that are shared from a Samba share location.
In this scenario, you notice that your application leaks file handles.

However, you do not experience this problem if one of the following conditions is true:
  • You run the application on a Microsoft Windows XP-based computer.
  • The application is linked to the Mfc42.dll file instead of to the Mfc42u.dll file.

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Cause

This occurs because of a code problem in the version of MFC that is included with the original release version of Windows Server 2003.

When an application uses the CFile::Open() method to open a file from a Samba share location, the Mfc42u.dll file calls its internal function to create a new file handle. However, the Mfc42u.dll file does not call its internal function later to release this handle.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required to apply this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Mfc42.dll6.6.8063.01,160,70409-Jun-200517:50x86SP1SP1QFE
Mfc42u.dll6.6.8063.01,163,77609-Jun-200517:50x86SP1SP1QFE

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information about this topic, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates


The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

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Keywords: kbautohotfix, kbwinserv2003presp2fix, kbhotfixserver, kbbug, kbfix, kbqfe, kbwinserv2003presp1fix, kbwinserv2003sp2fix, KB898902

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Article Info
Article ID : 898902
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 226