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A fix is available for a registry problem on Dell PowerEdge servers that have specific nonnative disk controllers and factory installed versions of Windows Server 2003


View products that this article applies to.

Symptoms

Certain Dell PowerEdge servers may have a latent problem in the registry. Although this registry problem may not currently be causing issues such as the issue that is described in this article, this registry problem could cause such issues in the future.

Because of this registry problem, you may receive a "Stop 0x00000051 (REGISTRY_ERROR)" error message when you run the Active Directory Installation Wizard to install Active Directory on a Microsoft Windows Server 2003-based member server. You may also receive this message after you install Windows Server 2003 Service Pack 1 (SP1).

This issue is known to occur with certain Dell PowerEdge servers that have a factory-installed version of Windows Server 2003 and use one of the following disk controller drivers:
  • Mraid35x.sys
  • Perc2.sys
  • A320raid.sys
  • Aac.sys
  • Symmpi.sys
  • Cercsr6.sys
  • Aarich.sys
  • Fasttx2k.sys
For more information about problems that are related to this issue, click the following article number to view the article in the Microsoft Knowledge Base:
898767� Windows Server 2003 Service Pack 1 is not available to install from the Microsoft Windows Update Web site

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Cause

This issue occurs because of a security counter mismatch problem in the registry that is caused by the original factory installation.

The issue may be latent. It may not cause errors until you run the Active Directory Installation Wizard or until you install Windows Server 2003 SP1. The registry error is more likely to occur when you upgrade a domain controller to Windows Server 2003 SP1.

If you are using a system that may be affected by this issue, we recommend that you install this update.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. To resolve the security counter mismatch problem in the registry and to prevent the registry error, apply the hotfix that is described in this article. When the system is restarted, this hotfix will proactively correct the registry problem as part of the typical registry integrity checking functions in the system kernel. This correction will eliminate the chance of any future errors that could be caused by this specific issue.

If you apply this hotfix to systems that do not have the specific registry problem that is described in this article, the hotfix will examine the integrity of the registry when the system is restarted and will find that there are no problems. The system will then continue to start correctly.

You can download this hotfix from the link in this article. Alternatively, you can have this hotfix automatically delivered to potentially affected systems through Windows Update or through Automatic Updates. If you are offered this hotfix through Windows Update, we recommend that you install the hotfix. Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The following file is available for download from the Microsoft Download Center:


Download the 898792 package now.

Release Date: June 28, 2005

For more information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591� How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

Note The security counter mismatch problem exists only on x86-based versions of Windows Server 2003 that have been installed by Dell. However, hotfix packages are also available to support x64-based and Itanium-based versions of Windows Server 2003.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, x86-based versions
   Date         Time   Version             Size  File name
   ----------------------------------------------------------
   05-May-2005  02:54  5.2.3790.325   2,408,960  Ntkrnlmp.exe
   05-May-2005  02:24  5.2.3790.325   2,065,920  Ntkrnlpa.exe     
   05-May-2005  02:24  5.2.3790.325   2,110,976  Ntkrpamp.exe
   05-May-2005  02:47  5.2.3790.325   2,208,768  Ntoskrnl.exe     
   04-May-2005  00:47  5.2.3790.324     355,840  Srv.sys
   05-May-2005  03:02  5.2.3790.2438  2,454,016  Ntkrnlmp.exe
   05-May-2005  02:43  5.2.3790.2438  2,267,136  Ntkrnlpa.exe     
   13-May-2005  22:51  5.2.3790.2438  2,308,096  Ntkrpamp.exe
   05-May-2005  03:02  5.2.3790.2438  2,415,616  Ntoskrnl.exe
Windows Server 2003, x64-based versions
   Date         Time   Version             Size  File name     Platform
   --------------------------------------------------------------------
   13-May-2005  22:51  5.2.3790.2438  4,417,536  Ntkrnlmp.exe  x64
   13-May-2005  22:51  5.2.3790.2438  4,444,672  Ntoskrnl.exe  x64
Windows Server 2003, Itanium-based versions
   Date         Time   Version             Size  File name     Platform
   --------------------------------------------------------------------
   13-May-2005  22:52  5.2.3790.325   5,609,984  Ntkrnlmp.exe  IA-64
   13-May-2005  22:52  5.2.3790.324     994,304  Srv.sys
   13-May-2005  22:51  5.2.3790.2438  6,482,944  Ntkrnlmp.exe  IA-64
This hotfix is scheduled to be included with Windows Server 2003 Service Pack 2.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

This issue was discovered shortly after Windows Server 2003 SP1 was shipped. Microsoft and Dell worked closely together to determine the issue's root cause and appropriate solutions. Microsoft implemented code on Windows Update to achieve the following two goals:
  • To detect potentially affected systems
  • To prevent Windows Update from offering to download Windows Server 2003 SP1 to vulnerable systems until an update has taken corrective actions. Vulnerable systems are those systems that could potentially be affected by the registry error.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
898767� Windows Server 2003 Service Pack 1 is not available to install from the Microsoft Windows Update Web site
Dell worked to provide a utility to fix currently unaffected systems. Dell also worked to provide the Dell RegFix utility so that systems that experience the error can recover. Microsoft posted information about this issue and a link to the issue's technical details and solutions on the Windows Server 2003 SP1 download Web site and in the release notes. Microsoft also worked to provide an integrated solution that could be offered through Windows Update. These efforts resulted in this hotfix solution.

As soon as you either apply the hotfix, Windows Update will detect that the system is no longer at risk. Windows Update will then offer SP1.

The hotfix is automatically offered through Windows Update, through Microsoft Software Update Services (SUS), and through Microsoft Windows Server Update Services (WSUS) to the same systems that are identified in the Dell article.

If all the following conditions are true, Windows Update determines that the system is potentially at risk and then offers the hotfix:
  • The C:\Dell.sdr file is present. The presence of this file indicates a Dell-installed version of Windows Server 2003.
  • Any one of the following specific nonnative disk driver files is present in the %windir%\System32 folder:
    • Mraid35x.sys
    • Perc2.sys
    • A320raid.sys
    • Aac.sys
    • Symmpi.sys
    • Cercsr6.sys
    • Aarich.sys
    • Fasttx2k.sys

Technical support for x64-based versions of Microsoft Windows

Your hardware manufacturer provides technical support and assistance for x64-based versions of Windows. Your hardware manufacturer provides support because an x64-based version of Windows was included with your hardware. Your hardware manufacturer might have customized the installation of Windows with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your x64-based version of Windows. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

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Keywords: kbhotfixserver, kbautohotfix, atdownload, kbwinserv2003sp2fix, kberrmsg, kbqfe, KB898792

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Article Info
Article ID : 898792
Revision : 13
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 375