Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The "Maximum number of VPN clients allowed" value is reset when you install ISA Server 2004 Enterprise Edition and join the server to an existing array


View products that this article applies to.

Symptoms

When you install Microsoft Internet Security and Acceleration (ISA) Server 2004, Enterprise Edition, and you join the computer to an existing ISA Server-based array, the Maximum number of VPN clients allowed value is reset to the default value.

Note Typically, the Maximum number of VPN clients allowed value is reset to 5. However, this value is reset to 100 if Microsoft Windows Server 2003 Service Pack 1 is installed on the ISA Server-based computer.

↑ Back to the top


Cause

This problem occurs when you join the ISA Server-based computer to an existing ISA Server-based array during the installation process. The SetVPNMaximumClients custom action resets the Maximum number of VPN clients allowed value.

↑ Back to the top


Resolution

For subsequent installations, do not reset the maximum number of IP addresses. You have to apply the update before you install a new firewall server. To do this, follow these steps:
  1. Copy the original ISA Server 2004 installation CD to a local share folder.
  2. At the command prompt, type the following command, and then press the ENTER key:
    msiexec /a <local share>\MS_FPC_Server.msi /p <update>

    Note The placeholder<local share> is a placeholder for the path of the MS_FPC_Server.msi file, such as C:\ISA 2004\FPC. The placeholder <update> is a placeholder for the name of the update that you want to install to the computer before you install a new ISA server.
  3. Start <local share>\Isaautorun.exe.
For more information about how to install ISA Server 2004 hotfixes and updates, click the following article number to view the article in the Microsoft Knowledge Base:
885957 How to install ISA Server hotfixes and updates

Service pack information

To resolve this problem, obtain the latest service pack for Internet Security and Acceleration Server 2004. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
891024 How to obtain the latest ISA Server 2004 service pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Size       File name
   -------------------------------------------------------------
   04-May-2005  23:25  1,018,880  Isa2004ee-kb898717-x86-enu.msp

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Internet Security and Acceleration Server 2004 Service Pack 2.

↑ Back to the top


More information

Steps to reproduce the problem

  1. Install ISA Server 2004 Enterprise Edition.
  2. Join the ISA Server 2004 Enterprise Edition-based computer to an existing ISA Server-based array. To do this, select Join an Existing Array on the Array Membership page during the installation process.
  3. When the installation process has completed, notice that the Maximum number of VPN clients allowed value has been reset to the default value.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: KB898717, kbhotfixserver, kbbug, kbfix, kbqfe, kbautohotfix

↑ Back to the top

Article Info
Article ID : 898717
Revision : 5
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 357