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Programs that you open appear to stop responding in Windows Server 2003


View products that this article applies to.

Symptoms

If you start a program on a Microsoft Windows Server 2003-based computer, the program takes a long time to start. Therefore, the program appears to stop responding. This symptom occurs if the Windows Server 2003-based computer is under a heavy load. Additionally, a program that is associated with the program that you start also appears to stop responding. The associated program appears to stop responding for the same period of time as the first program that you started. For example, you start Windows Explorer to locate a text file. After you double-click the text file to view the text file in Notepad, both Windows Explorer and Notepad appear to stop responding. It may take 15 minutes for the programs to start responding again.

Note
  • Programs appear to stop responding even though the processor load is 10 to 15 percent and the system disk is almost idle.
  • Typically, the Explorer.exe program is the associated program that appears to stop responding.

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Cause

This problem occurs if the Windows Server 2003-based computer experiences lots of Input/Output (I/O) traffic. For example, the Windows Server 2003-based computer experiences lots of I/O traffic if many File Transfer Protocol (FTP) connections are performing upload and download operations. The upload and download operations use I/O resources that include the Cache Manager. The Cache Manager is not disk-based, and the Cache Manager operates globally. Therefore, the problem occurs even if almost no load on the system disk exists. The high I/O traffic causes the cached disk transfers to build up. These cached disk transfers cause any read requests that are required to start new programs to stall. The read requests are delayed until the queue of cached disk transfers is cleared.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003 x86-based version
The following hotfix files are installed on a computer that has Windows Server 2003 Service Pack 1 (SP1) installed:
  Date        Time       Version        Size        File name
---------------------------------------------------------------------------
29-Apr-2005   22:27   5.2.3790.2433    2,452,992   Ntkrnlmp.exe
29-Apr-2005   16:16   5.2.3790.2433    2,266,624   Ntkrnlpa.exe 
29-Apr-2005   21:57   5.2.3790.2433    2,307,072   Ntkrpamp.exe
29-Apr-2005   22:27   5.2.3790.2433    2,414,592   Ntoskrnl.exe 

The following hotfix files are installed on a computer that does not have any Windows Server 2003 service pack installed:


Date        Time       Version        Size        File name
---------------------------------------------------------------------------
30-Apr-2005   00:38   5.2.3790.321     2,408,448   Ntkrnlmp.exe
29-Apr-2005   21:08   5.2.3790.321     2,065,408   Ntkrnlpa.exe   
29-Apr-2005   21:08   5.2.3790.321     2,110,464   Ntkrpamp.exe   
30-Apr-2005   00:21   5.2.3790.321     2,208,256   Ntoskrnl.exe    
Windows Server 2003 x64-based version
  Date      Time     Version         Size        File name
--------------------------------------------------------------
29-Apr-2005 16:17   5.2.3790.2433   4,416,512   Ntkrnlmp.exe 
29-Apr-2005 16:17   5.2.3790.2433   4,443,648   Ntoskrnl.exe 
Windows Server 2003 Itanium-based version
  Date      Time     Version         Size        File name
--------------------------------------------------------------
29-Apr-2005   16:17   5.2.3790.321   5,608,448   Ntkrnlmp.exe   IA-64
29-Apr-2005   16:17   5.2.3790.2433  6,477,312   Ntkrnlmp.exe   IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

After you install the hotfix, the cache manager prioritizes I/O requests that are related to new processes and bypasses the cache managers regular work queue.

For more information about the description of the standard terminology that is used to describe Microsoft updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbwinserv2003sp2fix, kbqfe, kbhotfixserver, kbbug, kbfix, kbwinserv2003presp1fix, kbautohotfix, KB898606

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Article Info
Article ID : 898606
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 250