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ISA Server 2004 may stop responding when IP addresses from multiple subnets are bound to the same adaptor


View products that this article applies to.

Symptoms

Consider the following scenario. In Microsoft Internet Security and Acceleration (ISA) Server 2004, you configure an adaptor that has two IP addresses from two different subnets. Then, you enable an application filter, such as the remote procedure call (RPC) filter. In this scenario, ISA Server 2004 may stop responding (hang). You may also experience the following symptoms:
  • Many packets are backlogged in ISA Server 2004.
  • CPU utilization increases on the ISA Server 2004 computer.
  • The Active Directory Application Mode (ADAM) server cannot open new RPC connections to this ISA Server 2004 computer.
  • The log viewer displays various reasons for why the ADAM server cannot open these RPC connections. These reasons include the following types of errors:
    • Errors that pertain to backlogged packets
    • The "FWX_E_TOO_BUSY" error

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Cause

The issue occurs when you use two IP addresses from different subnets to configure an adaptor. In this scenario, the ISA Server 2004 interpretation of the routing table differs from the interpretation that is made by the operating system. Specifically, ISA Server 2004 calculates a local IP address that is different from the real address that is used by the operating system. Therefore, ISA Server 2004 uses the wrong source IP address to create a state for the traffic. And when the traffic is inspected, no matching state is found. Therefore, ISA Server 2004 creates an additional mismatched state and then tries to resend the traffic. This process is repeated infinitely.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Internet Security and Acceleration Server 2004. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
891024 How to obtain the latest ISA Server 2004 service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

If you are running ISA Server 2004, Standard Edition, you must install ISA Server 2004 Service Pack 1. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
891024 How to obtain the latest ISA Server 2004 service pack

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
ISA Server 2004 Standard Edition
   Date         Time   Version            Size    File name
   ----------------------------------------------------------
   31-May-2005  00:48  4.0.2163.260      364,304  Msphlpr.dll  
 
ISA Server 2004 Enterprise Edition
   Date         Time   Version            Size    File name
   ----------------------------------------------------------
   27-Apr-2005  13:34  4.0.3440.260      394,008  Msphlpr.dll  

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Internet Security and Acceleration Server 2004 Service Pack 2.

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More information

For more information about how to install ISA Server 2004 hotfixes and updates, click the following article number to view the article in the Microsoft Knowledge Base:
885957 How to install ISA Server hotfixes and updates

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Keywords: KB898553, kbhotfixserver, kbprb, kbqfe, kbautohotfix

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Article Info
Article ID : 898553
Revision : 9
Created on : 12/4/2007
Published on : 12/4/2007
Exists online : False
Views : 361