Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: You receive an "AuthManager(CommerceServer): SiteConfig:Property 's_SecureHostname' not found in Admin Database" error message when you try to open a Web page of a Commerce Server 2002 Starter Site application


View products that this article applies to.

Symptoms

In Microsoft Commerce Server 2002, you receive the following error message when you try to open a Web page of a Commerce Server 2002 Starter Site application:
AuthManager(CommerceServer): SiteConfig:Property 's_SecureHostname' , not found in Admin Database, for MS-Commerce-Site 'starter1' .
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Runtime.InteropServices.COMException: AuthManager(CommerceServer): SiteConfig:Property 's_SecureHostname' , not found in Admin Database, for MS-Commerce-Site 'starter1' .

↑ Back to the top


Cause

This problem occurs because the AddressKeyName property in the Csapp.ini file references an application that does not exist.

Note The AddressKeyName property specifies the name of the application in the Administration database. The Csapp.ini file is located in the application root folder.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Commerce Server 2002 Service Pack 3 (SP3) installed on the computer.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   -----------------------------------------------------
   29-Apr-2005  01:32  4.5.3872.0  193,325  Mscsauth.dll

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

This hotfix does not correct the invalid application reference that is specified in the AddressKeyName property. However, this hotfix changes the error message that you receive when this problem occurs. The new error message will help you identify the problem so that you can correct the AddressKeyName property.

After you apply this hotfix, you receive the following error message when the AddressKeyName property in the Csapp.ini file references an application that does not exist:
AuthManager(CommerceServer): Error reading Commerce Server administration database. Check the AddressKeyName setting in the CSApp.ini file for the site and ensure that it refers to the name of a Commerce Server application that exists for the site. Site name: 'CS2002StarterSite' Application name: 'ApplicationName' Auth resource property: 's_SecureHostname' HRESULT: 0x800A0CC1 Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Runtime.InteropServices.COMException: AuthManager(CommerceServer): Error reading Commerce Server administration database. Check the AddressKeyName setting in the CSApp.ini file for the site and ensure that it refers to the name of a Commerce Server application that exists for the site. Site name: 'CS2002StarterSite' Application name: 'ApplicationName' Auth resource property: 's_SecureHostname' HRESULT: 0x800A0CC1
Note In this error message, ApplicationName is a placeholder for the name of the Commerce Server 2002 Starter Site application.

For more information about the terminology that Microsoft uses when Microsoft corrects software after it is released, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: KB898454, kbprb, kbfix, kbbug, kbcommserv2002presp4fix, kbconfig, kbqfe, kbhotfixserver, kbautohotfix

↑ Back to the top

Article Info
Article ID : 898454
Revision : 5
Created on : 11/15/2007
Published on : 11/15/2007
Exists online : False
Views : 345