Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

When you try to connect to an Outlook Mobile Access Web site on an Exchange 2003 computer, you may receive the "A System error has occurred while processing your request" error message


View products that this article applies to.

Symptoms

When you try to connect to a Microsoft Outlook Mobile Access (OMA) Web site on a Microsoft Exchange Server 2003 computer, you may receive the following error message:
A System error has occurred while processing your request. Please try again.

If the problem persists, contact your administrator.

↑ Back to the top


Cause

This behavior occurs if the following conditions are true:
  • You configure multiple Web sites in Microsoft Internet Information Services (IIS). You specify a different host header for each Web site. For example, you use the following host headers:
    • 10.0.0.2 80 mail.contoso.com

      Note This host header uses a digital certificate.
    • 10.0.0.2 80 admin.contoso.com
    • 10.0.0.2 80 www.contoso.com
    • 10.0.0.4 80 www.contosonet.net
  • The host header for the OMA Web site does not include the NetBIOS name of the Exchange 2003 computer.
The incoming requests are made to the /OMA virtual directory on the Exchange 2003 computer. These requests try to communicate by using the NetBIOS name of the /Exchange virtual directory. If the host header for the OMA Web site does not include the NetBIOS name, you receive the message that is mentioned in the Symptoms section.

↑ Back to the top


Workaround

To work around this behavior, you must add an additional host header that uses the NetBIOS name of the Exchange 2003 computer to the OMA Web site. To do this, follow these steps:
  1. Log on to the Exchange 2003 computer by using an account that has administrative permissions.
  2. Click Start, click Settings, and then click Control Panel.
  3. Double-click Administrative Tools, and then double-click Internet Information Services (IIS) Manager.
  4. Expand ServerName, expand Web Sites, right-click the Web site on which the /OMA virtual directory resides, and then click Properties.
  5. On the Web Site tab, click Advanced.
  6. Under Multiple identities for this Web site, click Add.
  7. Type the IP address in the IP Address box, type the port number in the TCP Port box, and then type the NetBIOS name of the Exchange 2003 computer in the Host Header value box.
  8. Click OK three times, and then quit IIS Manager.
  9. In Control Panel, double-click Services.
  10. Right-click IIS Admin service, and then click Restart.

↑ Back to the top


Status

This behavior is by design.

↑ Back to the top


Keywords: KB898131, kbprb, kbtshoot

↑ Back to the top

Article Info
Article ID : 898131
Revision : 5
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 237