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KB 897751 - You may receive an "Invalid user" error message in Business Portal


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Symptoms

In Business Portal for Microsoft Dynamics GP or for Microsoft Dynamics SL, you may receive the following error message when you click Site Settings and then click Manage Users:
Server Error in '/' Application.
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Invalid user.


Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.



Exception Details: Microsoft.BusinessFramework.Security.AuthenticationException: Invalid user.



Source Error: An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.



Stack Trace:


[AuthenticationException: Invalid user.] Microsoft.BusinessFramework.UserManager.VerifyUser() +695 Microsoft.BusinessFramework.EnterpriseSession.Initialize(String enterpriseUrl) +1061 Microsoft.BusinessFramework.Security.EnterpriseInitializationModule.OnAcquireRequestState(Object sender, EventArgs e) +150 System.Web.SyncEventExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute() +60 System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +87


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Version Information:
Microsoft .NET Framework Version:1.1.4322.2032;
ASP.NET Version:1.1.4322.2032

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Cause

This problem occurs when one or more of the following conditions are true:
  • The user account that was used to install Business Portal does not have the correct permissions on the server that is running Microsoft Internet Information Services (IIS). The user account is not a member of the correct roles on the computer that is running Microsoft SQL Server.
  • The user account is a member of a domain that is different from the domain in which Business Portal was installed.
  • The user account does not exist in the Business Portal tables in the Dynamics database or in the system database.
  • The user account is damaged in Business Portal.
  • Internet Enhanced Security is enabled.

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Resolution

To resolve this problem, follow these steps. After you complete each step, click Site Settings, and then click Manage Users in Business Portal. When you do not receive the error message that is mentioned in the "Symptoms" section, you will have resolved the problem. When that is true, you do not have to complete the remaining steps in this section. Each time that you receive the error message, go to the next step.
  1. Verify that the user account that was used to install Business Portal has at least local administrator permissions on the server that is running IIS. Also, make sure that the user account has a Microsoft SQL Server login. Make sure that the login is a member of the following server roles in SQL Server:
    • Security Administrators
    • Database Creators
  2. Make sure that the user account is a member of the domain and the network in which Business Portal is installed. Also, verify that the domain has a trusted environment set up in the network.
  3. Make sure that the user account that is receiving the error message exists in the following tables:
    • MbfUserWindowsIdentity
    • MbfUser

    To verify that the user account exists, run the following statement in SQL Query Analyzer or in SQL Server Management Studio. For Microsoft Dynamics GP, run the statement against the Dynamics database. For Microsoft Dynamics SL, run the statement against the system database.
    SELECT WINDOWSCREDENTIALS FROM MbfUserWindowsIdentity
    SELECT ALIAS FROM MbfUser
    If the user account does not exist in these tables, the user who installed Business Portal must remove and then add the user account by using Business Portal. For more information about how to remove or add a user account, see the "More Information" section.
  4. If the problem persists, have the user who installed Business Portal try to perform the task. If the user who installed Business Portal does not receive the error message, the user account of the user who received the error message may be damaged. The user who installed Business Portal must remove and then add the user account by using Business Portal. For more information about how to remove or add a user account, see the "More Information" section.
  5. On the IIS server, click Start, click Control Panel, click Add or Remove Programs, and then click Add/Remove Windows Components. Clear the Internet Enhanced Security check box, and then proceed through the wizard to remove the program.




    Notes
    • If you want to use Internet Enhanced Security, make sure that you log on by using a domain\userID user name together with the appropriate password.
    • Internet Enhanced Security is not necessary for a security check because Business Portal authenticates against the domain for each user who attempts to log onto the program.

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More Information

To remove and then add a user account in Business Portal, follow these steps.

Remove a user

  1. Start Business Portal. Use the user account that was used to install Business Portal.
  2. In Business Portal 3.0, click Site Settings, and then click Manage Business Portal users.

    In Business Portal for Dynamics GP 10 (and later versions), click Site Actions, click Site Settings, and then click Users in the Business Portal Administration section.
  3. In the User List list, select the user account.
  4. In the Pick a Task area, click Remove Users.
  5. In the Remove Business Portal Users window, click to select the user account that you want to remove.
  6. Click Remove.

Add a user

  1. Start Business Portal. Use the user account that was used to install Business Portal.
  2. In Business Portal 3.0, click Site Settings, and then click Manage Business Portal users.

    In Business Portal for Dynamics GP 10 (and later versions), click Site Actions, click Site Settings, and then click Users in the Business Portal Administration section.
  3. In the Pick a Task area, click Add new users. Complete the steps in the Add Users Wizard to add the user account to Business Portal.

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Keywords: kbnosurvey, kbmbsgp10,, kbfreshness2007, kbgreatplainsbp, kbmbsmigrate, kbbug, kb

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Article Info
Article ID : 897751
Revision : 2
Created on : 2/9/2018
Published on : 2/9/2018
Exists online : False
Views : 353