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A Windows Server 2003-based computer may repeatedly restart after you uninstall hotfix 842642


View products that this article applies to.

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/) Description of the Microsoft Windows registry

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Symptoms

A Microsoft Windows Server 2003-based computer may repeatedly restart after you uninstall hotfix 842642.

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Cause

This problem may occur if the following conditions occur in the order that they are listed:
1.You install security update 891711 on the computer.
2.You install hotfix 842642 on the computer.
3.You uninstall hotfix 842642.
This problem occurs because the Update.exe utility and the Spuninst.exe utility create the same temporary file name for the Winlogon.exe file and the Win32k.sys file.

Note The Update.exe utility and the Spuninst.exe utility are used to install and to remove Windows service packs and some hotfixes.

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Resolution

Note This problem may occur with packages that include a version Update.exe that is earlier than the 6.1.022.4 version.

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Status

To resolve this problem, either install a service pack or apply a hotfix. After you install the service pack or apply the hotfix, you must modify the registry to enable the fix. For more information, see the "More Information" section.

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces hotfix 842642.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, x86-based versions
   Date         Time   Version            Size  File name
   -------------------------------------------------------
   06-May-2005  02:24  5.2.3790.326  1,815,552  Win32k.sys
   06-May-2005  22:02  5.2.3790.326    292,352  Winsrv.dll
Windows Server 2003, Itanium-based versions
   Date         Time   Version            Size  File name   Platform
   -----------------------------------------------------------------
   05-May-2005  11:05  5.2.3790.326  4,959,744  Win32k.sys  x86
   06-May-2005  07:02  5.2.3790.326    766,464  Winsrv.dll  IA-64

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More information

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was first corrected in Windows Server 2003 Service Pack 1.

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References

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

Use hotfix 897703 instead of hotfix 842642 to fix a problem. If you already installed hotfix 842642, do not uninstall the hotfix.

If you install Windows Server 2003 Service Pack 1 or hotfix 897703, you must modify the registry to enable the fix. However, if you have already installed the 842642 hotfix and followed the instructions in that article to add the SupportLinkedFontConTextOut registry entry, you do not have to complete the following procedure.

To enable the fix, use one of the following methods:

Method 1. Modify the registry directly

To modify the registry directly, follow these steps:
1. Click Start, click Run, type regedit in the Open box, and then click OK.
2. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\GRE_Initialize
3. On the Edit menu, point to New, and then click DWORD Value.
4. Type SupportLinkedFontConTextOut as the entry name, and then press ENTER.
5. Right-click SupportLinkedFontConTextOut, and then click Modify.
6. In the Value data box, type 1, and then click OK.
7. Quit Registry Editor.
8. Restart the computer.

Method 2. Import the registry entry from a file

To import the registry entry from a file, follow these steps:
1. Start the Notepad program. To do this, click Start, click Run, type notepad.exe in the Open box, and then click OK.
2. Copy the following data, and then paste the data into Notepad:
Windows Registry Editor Version 5.00 

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\GRE_Initialize] 
"SupportLinkedConTextOut"=dword:00000001
3.On the File menu, click Save As.
4.Choose a location to save the file, and then type a descriptive name in the File name box. For example, type GRE_Initialize.reg as the file name.

Note When you save the file, you must use a .reg extension.
5.In the Save as type list, click All Files.
6.In the Encoding list, click Unicode.
7.Click Save.
8.Quit Notepad.
9. Double-click the .reg file that you saved in step 7. This action adds the registry entry.
10. When you are prompted whether you want to add the information to the registry, click Yes, and then click OK.
11.Restart the computer.

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Keywords: kbautohotfix, kbhotfixserver, kbqfe, kbwinserv2003sp1fix, kbwinserv2003presp1fix, kbbug, kbfix, KB897703

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Article Info
Article ID : 897703
Revision : 13
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 378