Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

VPN clients can no longer access internal resources after you install Windows Server 2003 Service Pack 1 on a computer that is running ISA Server 2000


View products that this article applies to.

Symptoms

After you install Microsoft Windows Server 2003 Service Pack 1 (SP1) on a computer that is running Microsoft Internet Security and Acceleration (ISA) Server 2000, remote virtual private network (VPN) clients who connect to internal resources through ISA Server 2000 can no longer access those resources.

When you perform additional troubleshooting on the client computer, you notice all the following symptoms:
  • The client computer successfully connects to the computer that is running ISA Server 2000 by using the VPN connection.
  • The user is successfully authenticated, and the client computer is successfully registered on the network.
  • The client computer has an IP address assigned to the wide area network (WAN) miniport virtual network adapter.
  • When you use the Ping.exe command to verify network connectivity, you notice that the client computer can only "ping" itself successfully. In this situation, the VPN client computer cannot connect to other computers.

↑ Back to the top


Cause

This problem occurs because of a change in Windows Server 2003 SP1. Windows Server 2003 SP1 enables the BootTimeSecurity registry entry. Therefore, after you install Windows Server 2003 SP1, the Windows Server 2003 Ipnat.sys driver drops VPN packets that it receives.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix Information

Prerequisites

No prerequisites are required to install this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003, x86-based versions
   Date         Time   Version        Size     File name
   -----------------------------------------------------
   04-May-2005  02:22  5.2.3790.2437  102,912  Ipnat.sys


Windows Server 2003, x64-based versions
   Date         Time   Version        Size     File name
   -----------------------------------------------------
   04-May-2005  16:42  5.2.3790.2437  155,648  Ipnat.sys


Windows Server 2003, Itanium-based versions
   Date         Time   Version        Size     File name
   -----------------------------------------------------
   04-May-2005  16:42  5.2.3790.2437  349,184  Ipnat.sys

Hotfix installation information

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you install this hotfix, you must set the value for the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\IpNat\Parameters
You must set this value as follows:
Value name: DisableBootTimeSecurity
Value type: REG_DWORD
Value data: 1
You must restart the server after you make this change to the registry.

Note For Windows Server 2003 Service Pack 2, you do not have to apply any hotfix. However, you have to enter the DisableBootTimeSecurity registry entry manually to resolve this problem. To do this, following these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following subkey in the registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\IpNat\Parameters
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type DisableBootTimeSecurity, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. Click Decimal, type 1 in the Value data box, and then click OK.

↑ Back to the top


Workaround

To work around this problem, remove Windows Server 2003 SP1.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was first corrected in Microsoft Windows Server 2003 Service Pack 2.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbwinserv2003sp2fix, kbqfe, kbHotfixServer, kbfirewall, kbbug, kbfix, KB897651

↑ Back to the top

Article Info
Article ID : 897651
Revision : 6
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 255