Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You may experience memory performance issues on a Windows Server 2003-based computer that is using an Intel Pentium 4 multiprocessor


View products that this article applies to.

Symptoms

On a Microsoft Windows Server 2003-based computer that is using an Intel Pentium 4 multiprocessor, you may experience the following issues:
  • An unexpectedly slow startup time.
  • Memory performance issues.
  • CPU spikes in the system process that occur immediately after startup.

↑ Back to the top


Cause

When a process allocates virtual memory, the Windows memory manager will clear the virtual memory pages before the memory manager lets the requesting process access the pages. This step makes sure that a process cannot access data in virtual memory that was previously owned by another process.

The page zeroing thread that is responsible for cleaning used memory pages is configured to use one of two instruction sets early in the startup process. By default, the page zeroing thread is configured not to use the extended memory manager interface (XMMI) instruction set on Pentium 4 multiprocessor systems. This restriction exists because of hardware issues that cause a decrease in performance on many Pentium 4 multiprocessor systems. Under certain conditions, the XMMI instruction set is incorrectly selected. This issue may be more common on single processor virtual machines that run on multiprocessor hosts. A virtual machine may incorrectly select the zeroing loop because the virtual machine detects a single processor during startup on a multiprocessor host.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, x86-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   14-Apr-2005  03:58  5.2.3790.309    2,407,936  Ntkrnlmp.exe
   14-Apr-2005  00:43  5.2.3790.309    2,064,896  Ntkrnlpa.exe     
   14-Apr-2005  00:43  5.2.3790.309    2,110,464  Ntkrpamp.exe
   14-Apr-2005  03:40  5.2.3790.309    2,208,768  Ntoskrnl.exe     
Windows Server 2003 with Service Pack 1 (SP1), x86-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   14-Apr-2005  03:46  5.2.3790.2421   2,452,480  Ntkrnlmp.exe
   14-Apr-2005  06:52  5.2.3790.2421   2,266,624  Ntkrnlpa.exe     
   14-Apr-2005  03:26  5.2.3790.2421   2,306,560  Ntkrpamp.exe
   14-Apr-2005  03:46  5.2.3790.2421   2,414,592  Ntoskrnl.exe     
Windows Server 2003, Enterprise Edition for Itanium-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   14-Apr-2005  06:53  5.2.3790.309    5,607,424  Ntkrnlmp.exe     IA-64
Windows Server 2003 with SP1, Enterprise Edition for Itanium-based Systems
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   14-Apr-2005  06:53  5.2.3790.2421   6,476,288  Ntkrnlmp.exe     IA-64
Windows Server 2003, x64-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   14-Apr-2005  06:53  5.2.3790.2421   4,416,000  Ntkrnlmp.exe     
   14-Apr-2005  06:53  5.2.3790.2421   4,443,648  Ntoskrnl.exe     

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows Server 2003 Service Pack 2.

↑ Back to the top


More information

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you install the hotfix, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then right-click the following registry subkey:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Kernel
  3. Right-click XMMIZeroingEnable, and then click Modify. If you want to force the system to use XMMI zeroing, set the XMMIZeroingEnable value to 1. If you want to force the system to use non-XMMI zeroing, set the XMMIZeroingEnable value to 2.
  4. Click OK.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

↑ Back to the top


Keywords: kbwinserv2003sp2fix, kbhotfixserver, kbqfe, kbbug, kbfix, kbwinserv2003presp1fix, kbautohotfix, KB897335

↑ Back to the top

Article Info
Article ID : 897335
Revision : 3
Created on : 9/11/2011
Published on : 9/11/2011
Exists online : False
Views : 326