Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A program that uses a remote access PPP connection to a Windows Server 2003-based computer is disconnected when the user logs off


View products that this article applies to.

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows registry

↑ Back to the top


Symptoms

A program that uses a remote access Point-to-Point Protocol (PPP) connection to a Windows Server 2003-based computer is disconnected when the user logs off. After the user logs off, the user cannot log back on.

↑ Back to the top


Cause

This problem may occur when software that uses a Remote Access Service PPP connection runs a service in the context of the Local System account. The problem occurs because remote access connections automatically disconnect when a user logs off from a remote access client. The default behavior is to disconnect remote access sessions that are associated with the logged on user and with the Local System account.

↑ Back to the top


Resolution

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To work around this problem, follow these steps:
  1. Run the service as a different account that has local Administrator rights instead of as the Local System account.
  2. Enable the KeepRasConnections key in the registry. To enable the KeepRasConnections key, follow these steps:
    1. Start Registry Editor.
    2. Locate and then click the following key in the registry:
      HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon
    3. On the Edit menu, click Add Value, and then add the following registry value:
      Value Name: KeepRasConnections
      Data Type: REG_SZ
      Value: 1
      Default Value: 0 (disabled)
    4. Quit Registry Editor.

↑ Back to the top


Status

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Microsoft Windows Server 2003 Service Pack 1 (SP1) installed.

Note Service Pack 1 is included in the x64-based and Itanium-based versions of Windows Server 2003.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, x86-based versions
   Date         Time   Version             Size  File name
   ----------------------------------------------------------
   21-Apr-2005  23:01  5.2.3790.314   1,192,448  Msgina.dll
   21-Apr-2005  23:01  5.2.3790.314     235,008  Rasapi32.dll
   21-Apr-2005  23:23  5.2.3790.314     540,672  Winlogon.exe
   21-Apr-2005  00:43  5.2.3790.314      59,392  Ws03res.dll
   22-Apr-2005  00:06  5.2.3790.2426    449,536  Licdll.dll
   21-Apr-2005  22:05  5.2.3790.2426  1,211,904  Msgina.dll
   21-Apr-2005  22:05  5.2.3790.2426    245,248  Rasapi32.dll
   21-Apr-2005  18:19  5.2.3790.2426    508,928  Winlogon.exe
Windows Server 2003, Itanium-based versions
   Date         Time   Version             Size  File name   Platform
   ------------------------------------------------------------------
   22-Apr-2005  00:06  5.2.3790.314   1,418,752  Msgina.dll     IA-64
   22-Apr-2005  00:06  5.2.3790.314     609,280  Rasapi32.dll   IA-64
   22-Apr-2005  00:06  5.2.3790.314     639,488  Winlogon.exe   IA-64
   22-Apr-2005  00:06  5.2.3790.314      58,880  Ws03res.dll    IA-64
   22-Apr-2005  00:06  5.2.3790.314   1,192,448  Wmsgina.dll      x86
   22-Apr-2005  00:06  5.2.3790.314     235,008  Wrasapi32.dll    x86
   22-Apr-2005  00:06  5.2.3790.314      59,392  Wws03res.dll     x86
   22-Apr-2005  00:06  5.2.3790.2426  1,465,856  Msgina.dll     IA-64
   22-Apr-2005  00:06  5.2.3790.2426    647,680  Rasapi32.dll   IA-64
   22-Apr-2005  00:06  5.2.3790.2426    680,448  Winlogon.exe   IA-64
   22-Apr-2005  00:06  5.2.3790.2426  1,211,904  Wmsgina.dll      x86
   22-Apr-2005  00:06  5.2.3790.2426    245,248  Wrasapi32.dll    x86
Windows Server 2003, x64-based versions
   Date         Time   Version             Size  File name   Platform
   ------------------------------------------------------------------
   22-Apr-2005  00:06  5.2.3790.2426    736,256  Licdll.dll       x64
   22-Apr-2005  00:06  5.2.3790.2426  1,193,472  Msgina.dll       x64
   22-Apr-2005  00:06  5.2.3790.2426    419,840  Rasapi32.dll     x64
   22-Apr-2005  00:06  5.2.3790.2426    922,112  Winlogon.exe     x64
   22-Apr-2005  00:06  5.2.3790.2426  1,211,904  Wmsgina.dll      x86
   22-Apr-2005  00:06  5.2.3790.2426    245,248  Wrasapi32.dll    x86

↑ Back to the top


More information

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

↑ Back to the top


Keywords: kbautohotfix, kbwinserv2003sp2fix, kbqfe, kbhotfixserver, KB897040

↑ Back to the top

Article Info
Article ID : 897040
Revision : 9
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 309