Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: The virtual catalog is not refreshed if impersonation is being used for the catalog Web service in Commerce Server 2002 Feature Pack 1


View products that this article applies to.

Symptoms

When you use Microsoft Commerce Server 2002 Feature Pack 1 (FP1) Catalog Manager to refresh a virtual catalog, the virtual catalog is not refreshed. Additionally, you may notice that the Status column in the Catalog Editor for the virtual catalog does not change to Up-to-date. Instead the status of the virtual catalog remains at Requires rebuilding.

↑ Back to the top


Cause

This problem may occur if impersonation is being used for the catalog Web service.

Note This hotfix changes the catalog assembly so that the catalog Web service correctly uses the impersonated identity for catalog refreshes.

↑ Back to the top


Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   --------------------------------------------------------------------
   25-Mar-2005  06:07  4.6.5232.0  393,216  Microsoft.catalogserver.dll  

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

After you apply the hotfix, you must use the Global Assembly Cache Tool (Gacutil.exe) to manually register the Microsoft .NET Framework assembly in the Global Assembly Cache (GAC). To register the assembly, type the following command at a command prompt, and then press ENTER:
gacutil /i Microsoft.catalogserver.dll /f
Note The Microsoft.catalogserver.dll assembly is typically located in the following folder:
C:\Program Files\Microsoft Commerce Server 2002\FP1\Assemblies
For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: KB896434, kbhotfixserver, kbqfe, kbprb, kbfix, kbbug, kbautohotfix

↑ Back to the top

Article Info
Article ID : 896434
Revision : 4
Created on : 11/15/2007
Published on : 11/15/2007
Exists online : False
Views : 365