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Web pages that use the DHTML editing ActiveX control may not work as expected after you install security update 891781 (MS05-013)


View products that this article applies to.

Symptoms

After you install security update 891781, when you try to run a program that uses the dynamic HTML (DHTML) editing component ActiveX control on a Microsoft Windows Server 2003-based computer or on a Microsoft Windows XP-based computer, you may receive the following error message:
No Such Interface Supported
Note Security update 891781 was issued in security bulletin MS05-013. For more information about security update 891781, click the following article number to view the article in the Microsoft Knowledge Base:
891781 MS05-013: Vulnerability in the DHTML editing component ActiveX control could allow code execution
Security update 891781 is included in Windows Server 2003 Service Pack 1.

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Cause

This problem occurs because security update 891781 makes changes to both the safe version and the unsafe version of the DHTML editing component ActiveX control.

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Resolution

Windows Server 2003

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

Prerequisites
No prerequisites are required.
Restart requirement
You do not have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dhtmled.ocx6.1.0.9232120,83212-Apr-200519:21x86NoneRTMQFE
Dhtmled.ocx6.1.0.9241132,60812-Apr-200519:22x86SP1SP1QFE

Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Wdhtmled.ocx6.1.0.9232120,83212-Apr-200507:30IA-64NoneWOW
Wdhtmled.ocx6.1.0.9241132,60812-Apr-200507:30IA-64SP1WOW

Windows Server 2003 x64-based versions
File nameFile versionFile sizeDateTimePlatform
Wdhtmled.ocx6.1.0.9241132,60812-Apr-200507:30x64

Windows XP

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must have Windows XP Service Pack 1 (SP1) or Windows XP Service Pack 2 (SP2) installed on the computer. For more information about how to obtain Windows XP Service Pack 1 or Windows XP Service Pack 2, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack
Restart requirement
You do not have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP Professional x64 Edition
File nameFile versionFile sizeDateTimePlatform
Wdhtmled.ocx6.1.0.9241132,60812-Apr-200507:30x64

Windows XP, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Wdhtmled.ocx6.1.0.9233118,27221-Apr-200517:58IA-64

Windows XP, x86-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dhtmled.ocx6.1.0.9233118,27222-Apr-200506:28x86SP1SP1QFE
Dhtmled.ocx6.1.0.9233128,51222-Apr-200505:03x86SP2SP2QFE

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

Your hardware manufacturer provides technical support and assistance for x64-based versions of Windows. Your hardware manufacturer provides support because an x64-based version of Windows was included with your hardware. Your hardware manufacturer might have customized the installation of Windows with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your x64-based version of Windows. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

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Keywords: kbautohotfix, kbqfe, kbHotfixServer, kbwinxpsp2fix, kbwinxpsp1fix, kbwinserv2003sp1fix, kbwinserv2003presp1fix, kbwinxp64bit2003sp1fix, kbbug, kbfix, kbwinserv2003sp2fix, KB896180

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Article Info
Article ID : 896180
Revision : 4
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 302