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Users notice incorrect presence information, and an event ID 30961 message is logged in Live Communications Server 2005


View products that this article applies to.

Symptoms

In your Microsoft Office Live Communications Server 2005 deployment, multiple front-end servers communicate with a back-end database server. In this scenario, you may experience one or more of the following symptoms:
Live Communications Server 2005 users notice incorrect presence information. For example, a user may appear to be online when that user is no longer online.
You notice that a queue of presence messages builds up on a particular front-end server. This symptom occurs if you use the Performance tool to monitor presence-related performance counters.
Users receive the following error message when they try to sign in to Live Communications Server 2005:
Signing in to SIP Communications Service failed because the service is temporarily unavailable. Please try again later.
You notice that the following event is logged in the Application event log of a particular front-end server:

Event Source: Live Communications
Event Category (1006)
Event ID: 30961
Data: date
Time: time
Type: Error
User: N/A
Computer: ComputerName
Description: Failed to connect to backend database. Live Communications Server will continuously attempt to reconnect to the backend. While this condition persists, incoming messages will receive error responses.

Backend: ServerName Database: databasename Connection string of: driver={SQL Server;Trusted_Connection=yes;AutoTranslate=no;server=ServerName;database=databasename
Cause: Possible issues with backend database.
Resolution:
Ensure the backend is functioning correctly.

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Cause

This problem may occur if one of the front-end servers in your Live Communications Server 2005 deployment experiences a loss of network connectivity. Even though only one front-end server may experience a loss of network connectivity, this problem may affect all the front-end servers in your enterprise pool.

In Live Communications Server 2005, front-end servers communicate with each other by using asynchronous RPC calls. A problem exists in Microsoft Windows Server 2003 that causes some of these RPC calls to become blocked when network connectivity to another front-end server is broken. In this scenario, the first front-end server stops functioning correctly.

Note You are more likely to experience this problem in an enterprise pool that contains only two front-end servers.

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Resolution

To resolve this problem, install Windows Server 2003 Service Pack 1 (SP1) on the front-end servers in your Live Communications Server 2005 deployment.

For more information about how to obtain Windows Server 2003 Service Pack 1, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

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Workaround

To work around this problem, restart the front-end server that lost network connectivity.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB896145, kbprb, kbtshoot, kbbug, kbfix, kbwinservnetwork

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Article Info
Article ID : 896145
Revision : 3
Created on : 3/24/2005
Published on : 3/24/2005
Exists online : False
Views : 310