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In Exchange 2000 Server, a recipient does not receive an attachment when you send an e-mail message together with a signed attachment


View products that this article applies to.

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows registry

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Symptoms

Consider the following scenario in Microsoft Exchange 2000 Server:
  • You send an e-mail message together with a signed attachment.
  • The signed attachment has the following MIME protocol type:
    Content-Type: application/pkcs7-signature
    name= test.pdf.p7s
When the recipient receives the e-mail message, the recipient does not receive the attachment.

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Cause

This problem occurs because the IMAIL component of the Microsoft Exchange Information Store service (Store.exe) cannot convert signed MIME attachments to Rich Text Format (RTF). Therefore, the attachment is stripped from the message and is no longer available in the messaging client.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3).

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
301378� How to obtain the latest Exchange 2000 Server service pack

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   18-Jul-2005  22:34  6.0.6617.79       262,144  Exmime.dll       
   16-Jul-2005  06:42  6.0.6617.79     2,342,912  Mdbmsg.dll       
   18-Jul-2005  22:34  6.0.6617.79     4,710,400  Store.exe        
				

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Status

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

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More information

After you install this hotfix, you must create and set a new DWORD value for the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent
To create and set the new DWORD value, follow these steps.

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. In the details pane, type the new value ConvertPKCS7SIGAttachmentToMAPI.
  5. Right-click ConvertPKCS7SIGAttachmentToMAPI, and then click Modify.
  6. In Edit DWORD Value dialog box, click Decimal under Base.
  7. In the Value data box, type 1, and then click OK.
  8. Quit Registry Editor.
Note If the ConvertPKCS7SIGAttachmentToMAPI DWORD value is set to 0 (zero), Exchange 2000 Server does not convert signed MIME attachments to RTF format.

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Keywords: KB895408, kbpubtypekc, kbbug, kbexchange2000presp4fix, kbfix, kbexchstore, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 895408
Revision : 5
Created on : 10/26/2006
Published on : 10/26/2006
Exists online : False
Views : 240