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You receive a "The parameter is incorrect (0x80050057)" error message or a "There is no such object on the server (0x80072030)" error message when you use a CDOEXM-based application on a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

When you run a program that uses Microsoft Collaboration Data Objects for Exchange Management (CDOEXM) functions on a Microsoft Windows Server 2003-based computer, you receive an error message that is similar to one of the following error messages:

Error message 1

The parameter is incorrect. (0x80050057)

Error message 2

There is no such object on the server. (0x80072030)

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Cause

On a Windows Server 2003-based computer, permissions for the Application event log have been locked down. This change causes CDOEXM initialization to fail if the program first calls CDOEXM. The program first calls CDOEXM when the program is running under the context of a user who does not have permissions to write to the Application event log. After this failure occurs, CDOEXM initialization will not be tried again until the program is restarted. Additionally, when the program subsequently calls CDOEXM, you may receive one of the error messages that are mentioned in the "Symptoms" section.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, this hotfix requires Microsoft Exchange Server 2003 Service Pack 1 (SP1).

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

After you install the hotfix, you must restart the Microsoft Exchange System Attendant, the IIS Admin Service, and all dependant services. If any other processes are using CDOEXM, you must also restart those processes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   14-Apr-2005  01:29  6.5.7233.7      2,844,160  Cdoexm.dll       

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Workaround

To work around this issue, grant the users of the CDOEXM program permissions to write to the Application event log. For information about the default permissions for the Application event log and about how to customize those permissions, visit the following Microsoft Web site:

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More information

Before you install this hotfix, when CDOEXM initialization fails, the error is not immediately returned. Additionally, initialization is not retried until the program is restarted. This behavior can cause future CDOEXM function calls to fail with unexpected errors.

The hotfix that is described in this article changes the behavior of CDOEXM so that initialization errors are immediately returned and so that no object is created. Additionally, any future attempts to create CDOEXM objects will cause CDOEXM to try to initialize again.

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
817903 New naming schema for Exchange Server software update packages

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Keywords: KB895404, kbbug, kbfix, kbexchdev, kbHotfixServer, kbqfe, kbAutoHotfix

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Article Info
Article ID : 895404
Revision : 4
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 348