Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You can take the MTA resource offline, but you cannot bring the MTA resource back online after you restart a Windows-based cluster


View products that this article applies to.

Symptoms

When you restart a Microsoft Windows-based cluster that is running Microsoft Exchange Server 2003, the Exchange 2003 message transfer agent (MTA) resource starts successfully. However, when you follow these steps, the MTA resource may fail:
  1. You right-click the MTA resource, and then you click Take Offline.
  2. You right-click the MTA resource, and then you click Bring Online.
Additionally, the following event may be logged in the Application event log:

Event ID: 3080
Event Type: Warning
Event Source: MSExchangeMTA
Event Category: Internal Processing
Description: A fatal MTA database server error was encountered.

↑ Back to the top


Cause

This problem typically occurs after the MTA resource releases a lock too early on an object that is not thread safe. Data is then incorrectly written to the Db000001.dat file. If any valid pointers to MTA queues are incorrectly written, the MTA resource may not start successfully.

Note The Db000001.dat file is located in the Exchsrvr\Mtadata folder.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Exchange Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires Exchange 2003 Service Pack 1 (SP1).

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   15-Feb-2005  22:32  6.5.7232.82     3,591,168  Emsmta.exe       
   

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Exchange Server 2003 Service Pack 2.

↑ Back to the top


More information

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
817903 New naming schema for Exchange Server software update packages

↑ Back to the top


Keywords: KB894094, kbexchange2003presp1fix, kbbug, kbfix, kbhotfixserver, kbqfe, kbautohotfix

↑ Back to the top

Article Info
Article ID : 894094
Revision : 8
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 300