Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The end-user-defined characters are not aligned correctly on a computer that is running the Japanese version of Windows XP or the Japanese version of Windows Server 2003


View products that this article applies to.

Symptoms

The end-user-defined characters (EUDC) are not aligned correctly in the graphical user interface (GUI) of some Japanese programs. This problem occurs on a computer that is running the Japanese version of Microsoft Windows XP or the Japanese version of Microsoft Windows Server 2003. This problem occurs even if you enable the Jpn98FixPitch registry entry on your computer.

Note This problem does not occur if you enable the Jpn98FixPitch registry entry on a computer that is running the Japanese version of Microsoft Windows 2000.

↑ Back to the top


Cause

This problem occurs because the EUDC character width is not calculated correctly even if the Jpn98FixPitch registry entry is enabled on the computer.

↑ Back to the top


Resolution

Windows XP hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To install this hotfix, you must have Windows XP Service Pack 2 (SP2) installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
User32.dll5.1.2600.16171,485,31228-Dec-200413:01IA-64SP1SP1QFE
Win32k.sys5.1.2600.16585,632,00001-Apr-200511:42IA-64SP1SP1QFE
Wuser32.dll5.1.2600.1617557,05628-Dec-200413:01x86SP1WOW
Windows XP, 32-bit versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
User32.dll5.1.2600.1617574,46429-Dec-200401:31x86SP1SP1QFE
Win32k.sys5.1.2600.16581,797,12002-Apr-200500:39x86SP1SP1QFE
Win32k.sys5.1.2600.26461,836,54402-Apr-200500:33x86SP2SP2QFE

Windows Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To install this hotfix, you must have the originally release version of Windows Server 2003 installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.4354,965,88831-Oct-200511:13IA-64
Windows Server 2003, 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.4351,818,11201-Nov-200501:06x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

The Jpn98FixPitch registry entry is located under the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\GRE_Initialize


Registry entry name: Jpn98FixPitch
Registry entry type: REG_DWORD
Value: 1 (enabled)
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbwinxpsp3fix, kbwinxppresp3fix, kbbug, kbfix, kbwinserv2003presp1fix, KB893614

↑ Back to the top

Article Info
Article ID : 893614
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 425