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Replication from the Site Replication Service on an Exchange Server 2003 computer to an Exchange Server 5.5 computer stops, and event IDs 1171 and 1082 are logged in the Application log


View products that this article applies to.

Symptoms

In your organization, replication from the Site Replication Service (SRS) on a Microsoft Exchange Server 2003 computer to a Microsoft Exchange Server 5.5 computer stops.

Additionally, if diagnostic logging is set to Maximum on the Exchange Server 5.5 computer, the following events may be logged in the Application log.

Event 1

Event ID: 1171
Event Type: Error
Event Source: MSExchangeDS
Event Category: Internal Processing
Description: Exception e0010004 has occurred with parameters -1026 and 0 (internal ID 206041c).

Event 2

Event ID: 1082
Event Type: Information
Event Source: MSExchangeDS
Event Category: Replication
Description: Replication warning: The directory replication agent (DRA) couldn't update object <OBJECT Distinguished Name> with changes made by directory <DIRECTORY Distinguished Name> because of error 22. The directory will try to update the object later. If this condition persists, try to free more disk space or stop and restart this Microsoft Exchange Server computer.

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Cause

This problem occurs because the Extensible Database Engine in Exchange 2003 creates packed pages objects for replication that are larger than 4 kilobytes (KB). However, the Extensible Database Engine in Exchange Server 5.5 (ESE97) supports replication of packed pages objects of only up to 4 KB.

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Resolution

You must install this hotfix on the Exchange 2003 SRS computer.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you install this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date	        Time   Version      Size     File name
   -----------------------------------------------------
   16-Feb-2005  16:53  6.5.7232.83  338,944  Srsmain.exe

Hotfix installation information

After you install the hotfix, the Active Directory Connector (ADC) will detect packed pages objects that are larger than 4 KB. The ADC will not replicate the packed pages objects to the SRS server. Additionally, when the ADC does not replicate a packed pages object that is larger than 4 KB, the ADC may log the following events in the Application log.
Event 1

Event Type: Error
Event Source: MSADC
Event Category: LDAP Operations
Event ID: 8270
Description:

"LDAP returned the error [1] Operations Error when importing the transaction
dn: cn=User1,cn=Recipients,ou=Your_Site,o=Your_Org
changetype: Modify msexchadcglobalnames:EX5:cn=User1,cn=Recipients,ou=Your_Site,o=Your_Org:organizationalperson$person$top0000...
: FOREST:69C3B70E835CB748937AAE7A92AAF3F3000000005AEC1AEFBB5CC501
: forest:o=eric0100000000826184EEBB5CC501
: NT5:7DD77629636E7847827398558C9EDEE9000000005AEC1AEFBB5CC501
ReplicatedObjectVersion:2
proxy-Addresses:Other_Mail_Program:User1 at Your_Site
: MS:Your_Org/Your_Site/User1
: smtp:101518@Child_Domain.Parent_Domain.Root_Domain

Note Hundreds of additional proxy addresses will appear here.

: smtp:2967a7@Child_Domain.Parent_Domain.Root_Domain;
-
(Connection Agreement 'Users: Parent_Domain.Root_Domain � Your_Site\Your_Org' #1576)

Event 2

Event Type: Error
Event Source: MSADC
Event Category: Replication
Event ID: 8109
Description: "Could not import the entry 'cn=User1,cn=Recipients,Your_Site,o=Your_Org ' into the directory server 'Domain_Controller. Parent_Domain.Root_Domain ' in the first attempt. (Connection Agreement 'Users: Parent_Domain.Root_Domain - Your_Site\Your_Org' #1576

Event 3

Event Type: Error
Event Source: MSADC
Event Category: Replication
Event ID: 8183
Description: "Could not import the entry 'cn=User1,cn=Recipients,Your_Site,o=Your_Org ' into the directory server 'Domain_Controller.Parent_Domain.Root_Domain' in the second attempt. (Connection Agreement 'Users: Parent_Domain.Root_Domain - Your_Site\Your_Org' #1576)

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
817903� New naming schema for Exchange Server software update packages

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Keywords: KB893608, kbbug, kbfix, kbexchange2003presp2fix, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 893608
Revision : 5
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 295