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A user is not successfully authenticated when NTLMv2 authentication is used on a Windows Server 2003-based IAS server


View products that this article applies to.



Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry

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Symptoms

Consider a scenario in which the following conditions are true:
  • A Microsoft Windows Server 2003-based Internet Authentication Service (IAS) server uses NTLM version 2 (NTLMv2) user authentication.
  • To connect to the IAS server, a client user uses a virtual private network (VPN) connection that uses Microsoft Challenge Handshake Authentication Protocol (MS-CHAP).
In this scenario, when the user uses the VPN connection to connect to the IAS server, the IAS server does not authenticate the user.

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Cause

This problem occurs because MS-CHAP is designed to be compatible only with NTLM version 1 authentication.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, 32-bit versions
   Date         Time   Version          Size  File name
-------------------------------------------------------
04-Feb-2005 02:57 5.2.3790.264 34,304 Aaaamon.dll
18-Oct-2004 14:12 5.2.3790.212 64,000 Eventlog.dll
04-Feb-2005 02:57 5.2.3790.264 102,400 Iassam.dll
04-Feb-2005 02:57 5.2.3790.264 801,792 Lsasrv.dll
04-Feb-2005 02:57 5.2.3790.264 130,048 Msv1_0.dll
04-Feb-2005 02:57 5.2.3790.264 108,544 Raschap.dll
Windows Server 2003, 64-bit versions
   Date         Time   Version            Size  File name     Platform
-------------------------------------------------------------------
03-Feb-2005 13:24 5.2.3790.264 62,464 Aaaamon.dll IA-64
17-Oct-2004 19:30 5.2.3790.212 167,936 Eventlog.dll IA-64
03-Feb-2005 13:24 5.2.3790.264 336,384 Iassam.dll IA-64
03-Feb-2005 13:24 5.2.3790.264 2,039,808 Lsasrv.dll IA-64
03-Feb-2005 13:24 5.2.3790.264 342,528 Msv1_0.dll IA-64
03-Feb-2005 13:24 5.2.3790.264 204,288 Raschap.dll IA-64
03-Feb-2005 13:27 5.2.3790.264 34,304 Waaaamon.dll x86
03-Feb-2005 13:27 5.2.3790.264 102,400 Wiassam.dll x86
03-Feb-2005 13:27 5.2.3790.264 130,048 Wmsv1_0.dll x86
03-Feb-2005 13:27 5.2.3790.264 108,544 Wraschap.dll x86

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To enable NTLMv2 authentication, you must add a new registry entry after you apply the hotfix. To do this, follow these steps.

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk. Note although the hotfix does not need to be installed on later versions the registry must still be set to enable NTLMv2.
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RemoteAccess\Policy
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type Enable NTLMv2 Compatibility, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. In the Value data box, type 1, and then click OK.
  7. Quit Registry Editor.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For additional information about NTLM authentication, click the following article numbers to view the articles in the Microsoft Knowledge Base:

239869 How to enable NTLM 2 authentication

147706 How to disable LM authentication on Windows NT

For additional information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbbug, kbfix, kbwinserv2003presp1fix

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Article Info
Article ID : 893318
Revision : 4
Created on : 5/27/2017
Published on : 5/27/2017
Exists online : False
Views : 967