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A printed document contains additional characters or words when you print a Web page that uses Adobe Type 1 fonts in Internet Explorer 6


View products that this article applies to.

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows registry

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Symptoms

When you print a Web page that uses Adobe Type 1 fonts, the printed document is incorrect. You may experience the following symptoms:
  • Characters from the beginning or the end of a line in the document are repeated on the next line in the printed document.
  • Words from the beginning or end of a line in the document are repeated on the next line in the printed document.
For example, you print the following text from a Web page:
Quick brown fox jumped over the lazy dog's back.
Quick brown fox jumped over the lazy dog's back.
Quick brown fox jumped over the lazy dog's back.
Quick brown fox jumped over the lazy dog's back.
In this situation, the printed text may appear similar to the following text:
Quick brown fox jumped over the lazy dog's back.
back .Quick brown fox jumped over the lazy dog's back.
back .Quick brown fox jumped over the lazy dog's back.
back .Quick brown fox jumped over the lazy dog's back.

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Cause

This problem occurs if you use Microsoft Internet Explorer 6. This is because there is an incompatibility with Adobe font rendering in the Internet Explorer 6 printing engine.

During the page layout process, Internet Explorer measures character widths by using the screen font. However, the MSHTML component in Internet Explorer forces the use of TrueType fonts. This is because certain Adobe fonts are not True Type fonts and because the display code path in Internet Explorer verifies the destination media. Therefore, a different set of widths exists for the characters that are printed.

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Resolution

Microsoft Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
You must have Internet Explorer 6 Service Pack 1 (SP1) installed to install this hotfix.
Restart requirement
You do not have to restart the computer after you apply this hotfix.

Note If the Mshtml.dll file is being used when you apply this hotfix, you must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, 32-bit versions
   Date         Time   Version       Size         File name
   ----------------------------------------------------------
   07-Apr-2005  21:32  6.0.3790.305  2,930,688    Mshtml.dll


Windows Server 2003, 64-bit versions
   Date         Time     Version       Size        File name
   ------------------------------------------------------------
   07-Apr-2005  19:30    6.0.3790.305  8,231,424   Mshtml.dll
   07-Apr-2005  19:32    6.0.3790.305  2,930,688   Wmshtml.dll
Hotfix installation information


Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you install this hotfix, you must set the following registry value to apply the changes that are included in this hotfix:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Printing


Value name: DO_NOT_FORCE_TRUETYPE_K893310
Value type: REG_DWORD
Value data: 0x1
In this registry value, a value of 0x1 enables compatibility support for Adobe fonts when you use them in Internet Explorer. To disable compatibility support for Adobe fonts in Internet Explorer, set this value to 0x0.

Microsoft Windows XP Service Pack 1 (SP1) and Windows XP Service Pack 2 (SP2)

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
You must have Internet Explorer 6 Service Pack 1 (SP1) installed to install this hotfix.
Restart requirement
You do not have to restart the computer after you apply this hotfix.

Note If the Mshtml.dll file is being used when you apply this hotfix, you must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP Service Pack 1
   Date         Time   Version        Size        File name
   ------------------------------------------------------------
   24-Mar-2005  17:35  6.0.2800.1502  2,703,360   Mshtml.dll


Windows XP Service Pack 2
   Date         Time   Version        Size        File name
   -----------------------------------------------------------
   25-Mar-2005  06:04  6.0.2900.2640  3,011,584   Mshtml.dll
Hotfix installation information


Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you install this hotfix, you must set the following registry value to apply the changes that are included in this hotfix:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Printing


Value name: DO_NOT_FORCE_TRUETYPE_K893310
Value type: REG_DWORD
Value data: 0x1
In this registry value, a value of 0x1 enables compatibility support for Adobe fonts when you use them in Internet Explorer. To disable compatibility support for Adobe fonts in Internet Explorer, set this value to 0x0.

Microsoft Windows 2000

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
You must have Internet Explorer 6 Service Pack 1 (SP1) installed to install this hotfix.
Restart requirement
You do not have to restart the computer after you apply this hotfix.

Note If the Mshtml.dll file is being used when you apply this hotfix, you must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time    Version        Size        File name
   ------------------------------------------------------------
   24-Mar-2005  17:35   6.0.2800.1502  2,703,360   Mshtml.dll
Hotfix installation information


Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you install this hotfix, you must set the following registry value to apply the changes that are included in this hotfix:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Printing


Value name: DO_NOT_FORCE_TRUETYPE_K893310
Value type: REG_DWORD
Value data: 0x1
In this registry value, a value of 0x1 enables compatibility support for Adobe fonts when you use them in Internet Explorer. To disable compatibility support for Adobe fonts in Internet Explorer, set this value to 0x0.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

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Keywords: kbautohotfix, kbbug, kbfix, kbqfe, kbwinserv2003presp1fix, kbmbsmigrate, kbhotfixserver, KB893310

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Article Info
Article ID : 893310
Revision : 8
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 499