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The Windows Firewall service in Windows XP Service Pack 2, in Windows XP Professional x64 Edition, in Windows Server 2003 SP1, and in x64-based versions of Windows Server 2003 cannot start if the DCOM Process Launcher Service is disabled


View products that this article applies to.

Symptoms

You cannot ping a computer that is running Microsoft Windows XP Service Pack 2 (SP2), Microsoft Windows XP Professional x64 Edition, Microsoft Windows Server 2003 Service Pack 1 (SP1), or an x64-based version of Microsoft Windows Server 2003. If you view the Windows Firewall service in the Services snap-in, the Windows Firewall/Internet Connection Sharing service has not started. This symptom occurs even if the startup type is set to automatic. If the Windows Firewall service cannot start, all incoming connections are refused until the Windows Firewall service starts successfully. Additionally, the status of the Network Connections service and the COM+ Event System service may be in a pending state.

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Cause

This problem occurs because the DCOM Server Process Launcher service (DCOMLAUNCH) startup type is set to disabled. This service is new to the products that are listed in the "Applies to" section, and this service must start before any DCOM-related services can successfully start.

If this service is not started, any DCOM-related services cannot start. Therefore, the Windows Firewall Service cannot start if the DCOM Server Process Launcher service is not started. This is because the Windows Firewall Service requires the DCOM component. Other services such as the Network Connections service and the COM+ Event System service are also dependent on the DCOM component.

Because the DCOM Server Process Launcher service is new, any security templates must be modified to support the new service. For example, security templates such as Group Policy settings or configuration scripts that restrict the DCOM Server Process Launcher service must be modified.

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Workaround

To work around this problem, configure the DCOM Server Process Launcher service to start automatically, and then restart the computer. To do this, follow these steps:
  1. Log on to the computer by using an account that has administrative permissions.
  2. Click Start, point to Administrative Tools, and then click Services.
  3. In the Services snap-in, right-click DCOM Server Process Launcher, and then click Properties.
  4. In the DCOM Server Process Launcher Properties dialog box, click the list next to Startup type click Automatic, and then click OK.
  5. Restart the computer.
Note If a Group Policy setting is restricting the DCOM Server Process Launcher service, you must contact your domain administrator to have the Group Policy setting updated to let this service run.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
892199 You cannot start the Windows Firewall service in Windows XP Service Pack

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB892504, kbtshoot, kbbug

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Article Info
Article ID : 892504
Revision : 10
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 427