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A WMI event notification query does not detect a user permissions change on Windows 2000 or Windows Server 2003


View products that this article applies to.

Symptoms

A WMI event notification query does not detect a user permissions change.

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Cause

This problem occurs because the access mask of the change event object is empty.

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Resolution

Windows 2000 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires Windows 2000 Service Pack 3 (SP3).

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   10-Jan-2005  05:26  1.50.1085.7019  1,093,727  Cimwin32.dll     

Windows Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-bit versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Jan-2005  02:24  5.2.3790.260    1,326,080  Cimwin32.dll     

Windows Server 2003, Enterprise Edition for Itanium-based Systems
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Jan-2005  02:22  5.2.3790.260    4,889,088  Cimwin32.dll

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

Steps to reproduce the problem

  1. Create a folder that has the name 000. For example, type md c:\000 at a command prompt, press ENTER, and then quit the command prompt.
  2. Click Start, click Run, type explorer, and then click OK.
  3. Locate and then right-click the folder that you created in step 1, click Properties, click the Security tab, and then click to select following permissions check boxes in the Allow column:
    Read & Execute
    List Folder Contents
    Read
    Special Permissions
    Note All other permissions check boxes in the Allow column must not be selected.
  4. Click Start, click Run, type wbemtest, and then click OK.
  5. Click Connect, type root\cimv2 in the Namespace box, and then click Connect.
  6. Click Query, type the following query, and then click Apply:
    SELECT * FROM __InstanceOperationEvent WITHIN 10 WHERE targetinstance ISA 'Win32_LogicalFileAccess' and TargetInstance.SecuritySetting='Win32_LogicalFileSecuritySetting.Path="c:\\\\000"'
  7. Switch to Explorer, locate and then right-click the folder that you created in step 1, and then click Properties.
  8. Click the Security tab, click Add, add a user who was not previously listed in the Group or user names list for the folder properties, and then click OK two times. You receive a notification in the Windows Management Instrumentation Tester tool Query Result dialog box.
  9. Double-click the InstanceCreationEvent=<nokey> event, double-click TargetInstance in the Properties list, and then double-click <embedded object> in the Value list to view the embedded object.

    Note that the AccessMask property in the Properties list has a value of <null>.
  10. Switch to Explorer, locate and then right-click the folder that you created in step 1, and then click Properties.
  11. Click the Security tab, click the user who you added in step 9 in the Group or user names list for the folder properties, click the Write check box in the Allow column in the Permissions for Users list, and then click OK. Note that you do not receive notification from the Windows Management Instrumentation Tester tool Query Result dialog box.
For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbwinserv2003presp1fix, kbbug, kbfix, kbwin2000presp5fix, KB892294

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Article Info
Article ID : 892294
Revision : 11
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 351