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A USB device that is connected to a USB 2.0 hub is not detected in Windows XP Service Pack 2, Windows Server 2003 Service Pack 1, or Windows Server 2003 x64 versions


View products that this article applies to.

Symptoms

If you connect a new universal serial bus (USB) device to a USB 2.0 hub on a computer, the computer does not detect the USB device. This symptom occurs if the computer is running one of the following operating systems:
  • Microsoft Windows XP Service Pack 2 (SP2)
  • Microsoft Windows Server 2003 Service Pack (SP1)
  • Microsoft Windows Server 2003 x64 versions
Additionally, other USB devices that are already connected to the computer stop functioning, and you have to restart the computer to detect the USB devices.

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Cause

This problem occurs because the Microsoft USB 2.0 driver causes an Enhanced Host Controller Interface (EHCI) specification violation.

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Resolution

Hotfix information for Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires that Windows XP SP2 is installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size     File name
   --------------------------------------------------------------
   31-Mar-2005  01:13  5.1.2600.2644      27,008  Usbehci.sys
   25-Feb-2005  03:53  6.1.22.4          371,936  Updspapi.dll

Service pack information for Windows Server 2003

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information for Windows Server 2003

Prerequisites

This hotfix requires that Windows Server 2003 SP1 is installed on the computer.

Note For Windows Server 2003 x64 versions, no prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, Itanium-based versions

   Date         Time   Version           Size     File name      Platform
   -------------------------------------------------------------------------
   26-Apr-2005  17:11  5.2.3790.2429      89,856  Usbehci.sys
   26-Apr-2005  17:11  6.1.22.4          639,712  Updspapi.dll   IA-64


Windows Server 2003, x64 versions

   Date         Time   Version           Size     File name      
   --------------------------------------------------------------
   26-Apr-2005  17:11  5.2.3790.2429      44,160  Usbehci.sys
   26-Apr-2005  17:11  6.1.22.4          462,560  Updspapi.dll



Windows Server 2003, 32-bit versions

   Date         Time   Version           Size     File name      
   --------------------------------------------------------------
   26-Apr-2005  03:43  5.2.3790.2429      27,520  Usbehci.sys
   05-Mar-2005  01:30  6.1.22.4          371,936  Updspapi.dll




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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbresolve, kbwinserv2003sp2fix, kbqfe, kbHotfixServer, kbwinxpsp3fix, kbwinxppresp3fix, kbfix, kbbug, kbautohotfix, KB892050

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Article Info
Article ID : 892050
Revision : 5
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 305