Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive a "STOP 0x0000007F" error message in Windows Server 2003 or in Windows 2000


View products that this article applies to.

Symptoms

On a Microsoft Windows Server 2003-based or a Microsoft Windows 2000-based computer, you experience any one of the following symptoms:
  • The computer automatically restarts.
  • After you log on, you receive the following error message:

    Microsoft Windows
    The system has recovered from a serious error.
    A log of this error has been created.
    Please tell Microsoft about this problem.
    We have created an error report that you can send to help us improve Microsoft Windows. We will treat this report as confidential and anonymous.
    To see what data this error report contains, click here .
    If the error message still appears and if you want to see the data that the error report contains, click the click here link at the bottom of the message box. Error signature information that is similar to the following appears:
    BCCode : 0000007F BCP1 : 00000008 BCP2 : 80042000 BCP3 : 00000000 
    BCP4 : 00000000 OSVer : 5_2_3718 SP : 0_0 Product : 272_3
  • You receive the following "Stop" error message on a blue screen:

    A problem has been detected and Windows has been shut down to prevent damage to your computer...
    Technical information:

    *** STOP: 0x0000007F (0x00000008, 0x80042000, 0x00000000, 0x00000000)
    UNEXPECTED_KERNEL_MODE_TRAP
  • An error message that is similar to the following is logged in the System event log:

    Date: date
    Source: System
    Error Time: time
    Category: (102)
    Type: Error
    Event ID: 1003
    User: N/A
    Computer: COMPUTER
    Description: Error code 0000007F, parameter1 00000008, parameter2 80042000, parameter3 00000000, parameter4 00000000. For more information, see Help and Support Center at http://support.microsoft.com. Data: 0000: 53 79 73 74 65 6d 20 45 System E 0008: 72 72 6f 72 20 20 45 72 rror Er 0010: 72 6f 72 20 63 6f 64 65 ror code 0018: 20 30 30 30 30 30 30 35 000007F 0020: 30 20 20 50 61 72 61 6d 0 Param 0028: 65 74 65 72 73 20 66 66 eters ff 0030: 66 66 66 66 64 31 2c

Notes

  • The Stop error message varies depending on the configuration of the computer's system failure options. For more information about how to configure system failure options, click the following article number to view the article in the Microsoft Knowledge Base:
    307973 How to configure system failure and recovery options in Windows
  • The four parameters that are listed in the Stop error description may vary depending on the computer's configuration.
  • Not all "Stop 0x0000007F" errors are caused by the problem that is described in this article.

↑ Back to the top


Cause

This problem occurs because of a stack overflow in a Windows kernel-mode thread. A stack overflow is caused by a function that consumes more space on a thread stack than is available. Windows generates a Stop error to prevent possible corruption of data that is adjacent to the thread stack location.

↑ Back to the top


Resolution

Windows Server 2003

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   09-Feb-2005  19:10  5.2.3790.267      619,008  Ntfs.sys

Windows 2000

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   14-Feb-2005  10:37  5.0.2195.7030     513,264  Ntfs.sys

↑ Back to the top


Status

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section. This bug was corrected in Windows Server 2003 Service Pack 1.

↑ Back to the top


Keywords: kbautohotfix, kbhotfixserver, kbqfe, kbocabucket, kbservicepack, kbbug, kberrmsg, kbfix, KB891722

↑ Back to the top

Article Info
Article ID : 891722
Revision : 7
Created on : 6/27/2007
Published on : 6/27/2007
Exists online : False
Views : 353