Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A multi-homed RIS server may not answer all clients, and you may receive an error message on PXE clients that are running Windows Server 2003 or Windows 2000


View products that this article applies to.

Symptoms

A multi-homed Remote Installation Service (RIS) server may not answer all clients. Additionally, you may receive an error message that is similar to the following on a Pre-Boot Execution Environment (PXE) client computer:

DHCP
No reply from a server
Press any key to reboot system
Depending on the client computer, the error message may differ. You may also receive additional error messages depending on the PXE basic input/output system (BIOS) of the computer or on the type of network adaptor.

When you examine the Application event log, there are no error messages from the Boot Information Negotiation Layer (BINL) service. The event log indicates that the server is authorized in the Active Directory directory service and can service clients. The multi-homed server is also running the Dynamic Host Configuration Protocol (DHCP) Server service with active and enabled scopes for each network adaptor.

Note A multi-homed server has either multiple network adaptors or multiple static IP addresses that are configured for a single network adaptor. To use RIS on a multi-homed system, you must run the DHCP Server service. Additionally, each network adaptor must have an active and enabled scope. If not, PXE client computers are not answered by the server.

↑ Back to the top


Cause

This issue may occur if you run the RIS service on a multi-homed server.

Note We do not recommend that you run the RIS service on a multi-homed server.

↑ Back to the top


Resolution

To resolve this issue, follow these steps:
  1. Verify the RIS installation. To do this, follow these steps:
    1. In Active Directory Users and Computers, click Domain Controllers.
    2. In the details pane, right-click the RIS server, and then click Properties.
    3. On the Remote Install tab, verify that the Respond to client computers requesting service check box is selected.
    4. Verify that the Do not respond to unknown client computers check box is not selected unless the client computers that are experiencing this issue have been pre-staged in Active Directory with a GUID. Use this option only if you used GUID information to add the client computers that you intend to install by using RIS PXE startup or the RIS boot disk.
  2. Verify that the RIS server is authorized to perform the BINL service on the network. To do this, follow these steps:
    1. In the DHCP management console, click the DHCP root object in the console tree.
    2. On the Action menu, click Manage Authorized Servers.
    3. Verify that the RIS server is on the authorized servers list. If it is not on the list, click Add, and then type the IP address or the server name to add the RIS server to the list of authorized servers.
  3. Review the Application log for the RIS server. The follow messages should be logged:
    3/6/2001 11:51:05 AM BINLSVC Information None 1003 N/A COMPUTERNAME The BINL service successfully read its settings from the directory service.
    3/6/2001 11:42:52 AM DhcpServer Information None 1044 N/A COMPUTERNAME The DHCP/BINL service on the local machine, belonging to the Windows Administrative domain domainname.com, has determined that it is authorized to start. It is servicing clients now.

↑ Back to the top


Workaround

Although we do not recommend that you run the RIS service on a multi-homed server, you may be able to work around issues with this configuration. For a multi-homed RIS server to work, the following conditions must be true:
  • The DHCP Server service is installed on the RIS server.
  • Scopes are defined on the DHCP server.
  • The DHCP server scopes are active.

↑ Back to the top


More information

This section discusses issues that you may experience when you run the RIS service on a multi-homed server.

Assume that you have installed and started the RIS and DHCP Server services on the same server. If the RIS client is across a router, the RIS client may not be able to obtain an IP address during the PXE startup. The RIS client may receive a DHCP offer of all zeros. The RIS client may work correctly if you move the RIS and DHCP Server services to separate computers or if you remove the router.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
300034� Your RIS client may not be able to obtain an IP address during the PXE restart on Windows Server 2003 and Windows 2000

A multi-homed RIS server that is configured with two or more network adaptors may not answer all clients. A PXE client may display an error message.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260521� Multi-homed RIS server may not answer all PXE clients

After you install Microsoft Windows 2000 Service Pack 2 (SP2) on your computer, the DHCP Server service cannot be authorized by Active Directory. Although the DHCP server requests authorization from Active Directory every five minutes, DHCP clients cannot obtain a lease or an address, and the System event log may contain an error.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
303525� Invalid LDAP filter for DHCP server authorization

PXE clients require an IP address from a DHCP server to begin the installation process from a RIS server. If the PXE client is located across a router from the DHCP server or from the RIS server, the client may not receive an IP address from the DHCP server or configuration information from the RIS server. If this information is not available, the installation on the PXE client does not work.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
257579� PXE clients do not receive an IP address from a DHCP server across a router

↑ Back to the top


Keywords: KB891372, kbprb, kbtshoot

↑ Back to the top

Article Info
Article ID : 891372
Revision : 4
Created on : 11/1/2006
Published on : 11/1/2006
Exists online : False
Views : 349