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You may receive an error that the password does not meet the requirements when you use LDAP to change passwords in Windows Server 2003


View products that this article applies to.

Symptoms

Consider the following scenario:
You use the Lightweight Directory Access Protocol (LDAP) to change passwords on a Microsoft Windows Server 2003-based computer.
You use the LDAP API from an application by using the ldap_add call.
You find that the ldap_add call fails.
When the ldap_add call fails, you may receive an error that the password does not meet the requirements.
In this scenario, the problem occurs if the order of the attributes is incorrect. For example, the problem occurs if the unicodepwd attribute is not passed in before the useraccountcontrol attribute.

Note This problem only occurs in Windows Server 2003 and does not occur in Microsoft Windows 2000.

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Cause

This problem occurs because there is a problem in the Samsrv.dll file.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Samsrv.dll5.2.3790.256465,92025-Jan-200516:38x86
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Samsrv.dll5.2.3790.2561,038,33625-Jan-200500:37IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 1.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB891299, kbpubtypekc, kbqfe, kbhotfixserver, kbfix, kbbug, kbautohotfix

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Article Info
Article ID : 891299
Revision : 7
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 335