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FIX: You may intermittently receive the "SQLSTATE: 08S01, SQLCODE: -605" error message when you perform distributed transactions over TCP/IP by using the OLE DB Provider for DB2 in Host Integration Server 2004


View products that this article applies to.

Symptoms

When you perform distributed transactions over TCP/IP by using the OLE DB Provider for DB2 that is included with Microsoft Host Integration Server 2004, you may intermittently receive the following error message:
SQLSTATE: 08S01, SQLCODE: -605
When this problem occurs, the network connection is closed between the system that is using the OLE DB Provider for DB2 and the remote system that is running IBM DB2.

SQLCODE -605 is defined as DB2OLEDB_COMM_SOCKET_REC_FAILED. This error indicates that the OLE DB Provider for DB2 could not receive the data.

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Cause

This problem occurs when the Host Integration Server TCP/IP Resync service (DRDAResync.exe) receives chained Distributed Data Management (DDM) code points from a remote DB2 system to roll back a failed transaction. The TCP/IP Resync service does not correctly parse chained DDM code points.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   -------------------------------------------------------
   18-Dec-2004  23:57  6.0.1923.0  336,384  Drdaresync.exe
Note Because of file dependencies, the most recent hotfix that contains these files may contain additional files.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

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Keywords: KB891062, kbbug, kbfix, kbhis2004, kbqfe, kbHotfixServer, kbautohotfix

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Article Info
Article ID : 891062
Revision : 2
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 423