Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Framework.log file size exceeds the value that is set for the Log File Max Size subkey entry when you use WMI on a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

When you use Windows Management Instrumentation (WMI) and configure WMI to log events on a Microsoft Windows Server 2003-based computer, the size of the WMI Log file, FrameWork.log, may continue to increase even after the FrameWork.log file has exceeded the Log File Max Size subkey entry.

Note By default, the value of the Log File Max Size subkey is set to 64 kilobytes (KB).

↑ Back to the top


Cause

This problem occurs when the Windows Server 2003 Network Service account does not have Delete permissions on the %Systemroot%\System32\Wbem\Logs folder.

↑ Back to the top


Resolution

Resolution for Windows Server 2003

This hotfix resolves the problem only on a computer on which a clean installation of Windows Server 2003 was performed. This hotfix does not resolve the problem on a computer on which Windows Server 2003 Service Pack 1 was applied to the release version of Windows Server 2003.

Resolution for Windows Server 2003 with Service Pack 1

To resolve this issue on Windows Server 2003 with Service Pack 1, follow the steps in the Microsoft Knowledge Base article 836605. These steps describe how to modify the security settings on the %systemroot%\system32\wbem\logs folder so that the Network Service account has the Delete permission. For more information about how to modify the security settings, click the following article number to view the article in the Microsoft Knowledge Base:
836605 The Framework.log file grows larger than 64 KB when you use WMI on a Windows Server 2003 or Windows XP computer

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003, 32-bit versions

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   10-Dec-2004  19:40  5.2.3790.241      216,576  Wbemcomn.dll     
   10-Dec-2004  19:40  5.2.3790.241      467,968  Wbemcore.dll     

Windows Server 2003, Itanium-based versions

   Date         Time   Version            Size    File name      Platform
   ----------------------------------------------------------------------
   10-Dec-2004  19:40  5.2.3790.241      612,864  Wbemcomn.dll   IA-64
   10-Dec-2004  19:40  5.2.3790.241    1,724,416  Wbemcore.dll   IA-64

↑ Back to the top


More information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows


You can configure the WMI error log by changing the registry:
  • The destination folder for all log files is set by the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Microsoft\WBEM\CIMOM\LoggingDirectory
  • The maximum file size is set by the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Microsoft\WBEM\CIMOM\Log File Max Size
The following registry subkey determines how the Windows Driver Model (WDM) provider logs errors:
HKEY_LOCAL_MACHINE\Software\Microsoft\WBEM\CIMOM\Logging


The logging entry uses the following values:
  • 0: Turns off logging
  • 1: Logs errors only
  • 2: Starts verbose logging
When a log file reaches the value set for the Log File Max Size subkey entry, the log file is backed up to Log_file_name.lo_, and a new log file starts to collect entries. The only exception is the Framework.log file. The Framework.log file may continue to increase even after the file exceeds the value set for the Log File Max Size subkey entry.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbbug, kbfix, kbwinserv2003presp1fix, KB891011

↑ Back to the top

Article Info
Article ID : 891011
Revision : 4
Created on : 4/17/2008
Published on : 4/17/2008
Exists online : False
Views : 452