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"TOO_MANY_OPEN_FILES" error message when the redirector component in Windows Server 2003 uses the SMB protocol to open a file in a shared network folder


View products that this article applies to.

Symptoms

When the redirector component in Microsoft Windows Server 2003 uses the Server Message Block (SMB) protocol to open a file that is located in a shared network folder, you may receive the following error message:
The system cannot open the file.
When you use Network Monitor to trace the network traffic, you may receive the following error message:
TOO_MANY_OPEN_FILES
Additionally, when you use the Open Handles (OH) monitoring tool (Oh.exe) to view the open handles of the client process, no open handles are reported.

Note The OH monitoring tool shows the handles of all open windows. Alternatively, you can limit the OH display to show only information relating to a particular process, object type, or object name. This feature is useful when a sharing violation occurs because you can find the process that has a file open at the time of violation.

However, when you run the Net Files command at a command prompt on the Windows Server 2003-based computer to view the handles that are opened by clients, there may be hundreds or even thousands of files open.

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Cause

This problem occurs when the files in the dormant file cache are not closed correctly.

By default, the redirector component in Windows Server 2003 does not immediately close files on the server for performance reasons. However, the closed files are cached in this scenario. This problem may occur on the Windows Server 2003-based computer even though no error message is displayed.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 64-bit editions
   Date         Time   Version            Size    File name
   ---------------------------------------------------------
   24-Nov-2004  01:39  5.2.3790.235    1,124,864  Mrxsmb.sys
   24-Nov-2004  01:39  5.2.3790.235      465,408  Rdbss.sys
Windows Server 2003, 32-bit editions
   Date         Time   Version            Size    File name
   ---------------------------------------------------------
   24-Nov-2004  01:34  5.2.3790.235      395,776  Mrxsmb.sys
   24-Nov-2004  01:34  5.2.3790.235      158,720  Rdbss.sys

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More information

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk. By default, the number of closed files that can be cached is 45. This setting is controlled by the DormantFileLimit registry value. This registry value is located under the following subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet \Services\LanmanWorkstation\Parameters

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbbug, kbfix, kbwinserv2003presp1fix, KB890584

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Article Info
Article ID : 890584
Revision : 11
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 375