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You may experience delays of between 10 and 60 seconds when you use UNC paths to access files that are stored on a remote SMB server on a multihomed Windows Server 2003-based computer


View products that this article applies to.

Symptoms

On a multihomed computer that is running Microsoft Windows Server 2003, you may experience delays of between 10 and 60 seconds when you use Universal Naming Convention (UNC) paths to access files that are stored on a remote server message block (SMB) server. This problem occurs more frequently as your computer tries to access files more frequently. For example, the problem may occur when an application tries to access files at two second intervals. The problem does not occur when you access the files through a mapped network drive. The problem also does not occur when NetBIOS over TCP/IP (NetBT) is disabled on at least one network interface.

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Cause

This problem occurs because of a timing problem between the SMB redirector and the NetBT driver.

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Resolution

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.To resolve this problem, install the following hotfix. Then, modify the registry to add the ScavengerTimeLimit registry entry.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-bit versions
   Date         Time   Version            Size  File name
   -------------------------------------------------------
   01-Dec-2004  14:33  5.2.3790.238    395,776  Mrxsmb.sys
   01-Dec-2004  14:33  5.2.3790.238    158,720  Rdbss.sys
Windows Server 2003, Enterprise Edition for Itanium-based Systems
   Date         Time   Version            Size  File name
   -------------------------------------------------------
   30-Nov-2004  22:37  5.2.3790.238  1,124,864  Mrxsmb.sys
   30-Nov-2004  22:37  5.2.3790.238    465,408  Rdbss.sys
To add the ScavengerTimeLimit registry entry, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters
  3. Right-click
    parameters
    , point to New, and then click DWORD Value.
  4. Type ScavengerTimeLimit, and then press ENTER to name the new registry entry.
  5. Double-click ScavengerTimeLimit.
  6. In the Value data box, type 30, and then click OK.

    Note You can enter any value between 10 and 120 to control how frequently the Scavenger thread cleans up old connections. If you still experience the problem after you set the value to 30, increase the value.

    Important Increasing the value uses more resources on both the local computer and the remote SMB server. If you set the ScavengerTimeLimit registry entry to more than 30, we recommend that you monitor the paged pool usage and the non-paged pool usage on both computers.
  7. Quit Registry Editor.

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Workaround

To work around this problem, follow these steps:
  1. Map a network drive to the SMB server. To do this, follow these steps:
    1. Start Windows Explorer.
    2. On the Tools menu, click Map Network Drive.
    3. In the Drive list, click a drive letter.
    4. In the Folder list, type the UNC path of the shared resource on the server.

      Use the following format:
      \\ServerName\SharedItem
      Alternatively, click Browse and locate the shared resource.
    5. Click Finish.
  2. Disable NetBT on a network interface. To do this, follow these steps:
    1. Click Start, click Run, type ncpa.cpl, and then click OK.
    2. Right-click the network connection that you want to configure, and then click Properties.
    3. If the connection is a local area connection, click the General tab, click Internet Protocol [TCP/IP] in the This connection uses the following items box, and then click Properties.

      If the connection is not a local area connection, click the Networking tab.
    4. Click Advanced, and then click the WINS tab.
    5. In the NetBIOS setting area, click Disable NetBIOS over TCP/IP.
    6. Click OK three times.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For additional information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbbug, kbfix, kbwinserv2003presp1fix, KB890553

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Article Info
Article ID : 890553
Revision : 12
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 347