Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Folders are still visible when you access a mailbox after you configure segmentation for your users to exclude certain folders in Exchange 2003


View products that this article applies to.

Symptoms

After you configure segmentation for your users to exclude certain folders, these folders are still visible when you access the mailbox. This problem occurs when the following conditions are true:
  • You exclude folders such as the Contacts folder and the Tasks folder.
  • You use an Internet Message Access Protocol (IMAP) e-mail client such as Microsoft Outlook Express to access the mailbox.
This problem occurs in Microsoft Exchange Server 2003.

↑ Back to the top


Cause

Segmentation is implemented for Microsoft Outlook Web Access. However, it is not implemented for IMAP e-mail clients.

↑ Back to the top


Resolution

To resolve this problem, you must install a hotfix. After you install the hotfix, you must configure the value of the imap4svc/1 metabase key so that you can exclude folders in an IMAP e-mail client. For the hotfix and the configuration to work, the user must first access the mailbox by using Outlook Web Access.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires Microsoft Exchange Server 2003 Service Pack 1.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version      Size      File name
--------------------------------------------------------------
03-Dec-2004  23:51  6.5.7232.56  82,432    Eximap4.dll
03-Dec-2004  23:51  6.5.7232.56  21,504    Expop3.dll
03-Dec-2004  23:51  6.5.7232.56  23,040    Exproto.dll
03-Dec-2004  23:51  6.5.7232.56  27,648    Febecfg.dll
03-Dec-2004  23:51  6.5.7232.56  19,968    Iisif.dll
03-Dec-2004  23:51  6.5.7232.56  131,072   Iisproto.dll
03-Dec-2004  23:51  6.5.7232.56  56,320    Imap4be.dll
03-Dec-2004  23:51  6.5.7232.56  122,368   Imap4fe.dll
03-Dec-2004  23:51  6.5.7232.56  119,808   Imap4svc.dll
03-Dec-2004  23:51  6.5.7232.56  107,520   Imapadm.dll
03-Dec-2004  23:51  6.5.7232.56  7,168     Imapapi.dll
03-Dec-2004  23:52  6.5.7232.56  23,552    Letadata.dll
03-Dec-2004  23:51  6.5.7232.56  107,520   Pop3adm.dll
03-Dec-2004  23:51  6.5.7232.56  7,168     Pop3api.dll
03-Dec-2004  23:52  6.5.7232.56  26,112    Pop3be.dll
03-Dec-2004  23:52  6.5.7232.56  12,288    Pop3fe.dll
03-Dec-2004  23:51  6.5.7232.56  68,096    Pop3svc.dll

Configure the metabase key

To set the value for the imap4svc/1 metabase key and to initialize segmentation, follow these steps:
  1. Install the Mdutil.exe utility on your computer.
    1. Insert the Microsoft Windows 2000 CD into your CD drive.
    2. At the command prompt, type the following:
      expand -r CD_drive_letter:\i386\mdutil.ex_ c:\winnt
  2. Enable hidden folders so that the excluded folders do not appear in the IMAP e-mail client. To do this, type the following at the command prompt:
    mdutil set -dtype DWORD -path imap4svc/1 -prop 49886 -value 0
  3. Instruct your user to use Outlook Web Access to access the mailbox after you configure the metabase key.
Note To disable hidden folders so that the excluded folders do appear in the IMAP e-mail client, type the following at the command prompt:
mdutil set -dtype DWORD -path imap4svc/1 -prop 49886 -value 1

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For additional information about how to use segmentation in Exchange Server 2003, click the following article number to view the article in the Microsoft Knowledge Base:
833340� How to modify the appearance and the functionality of Outlook Web Access by using the segmentation feature in Exchange 2003
For additional information about hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
817903� New naming schema for Exchange Server software update packages

↑ Back to the top


Keywords: KB890550, kbbug, kbfix, kbexchange2000presp2fix, kbhotfixserver, kbqfe, kbautohotfix

↑ Back to the top

Article Info
Article ID : 890550
Revision : 7
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 303