Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You cannot automatically log on by using the AutoLogonCount and AdminPassword options after you use Sysprep.exe on Windows Server 2003


View products that this article applies to.

Symptoms

You cannot automatically log on to your computer after you install Microsoft Windows Server 2003 by using the System Preparation (Sysprep.exe) tool with the AutoLogonCount and the AdminPassword answer file (Sysprep.inf) options.

You may also receive the following message:
The system could not log you on. Make sure your User name and domain name are correct, then type your password again. Letters in passwords must be typed using the correct case.

↑ Back to the top


Cause

This issue occurs when the following conditions are true:
  • The computer where the Sysprep tool master image is created has the DefaultPassword registry entry located in the following Windows registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
  • You use the AutoLogonCount and AdminPassword answer file options for the installation.
  • You run the Sysprep tool to perform an unattended installation of Windows Server 2003 by using the master image and answer files that are described in this section.

↑ Back to the top


Resolution

To resolve this issue, remove the DefaultPassword registry entry from the Windows registry on the master computer. Then re-create the image by using the Sysprep tool. To do this, follow these steps on the Windows Server 2003-based computer that will be used to create the master image.

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
  3. Right-click DefaultPassword, click Delete, and then click Yes.
  4. Quit Registry Editor.
  5. Re-create the master image by using the Sysprep tool.

↑ Back to the top


Keywords: KB889715, kbprb, kbtshoot, kbsetup, kbwinservsetup, kbsyspreptool

↑ Back to the top

Article Info
Article ID : 889715
Revision : 3
Created on : 10/30/2006
Published on : 10/30/2006
Exists online : False
Views : 247