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You receive a "The page cannot be found" error message or a blank "Web Page Dialog" dialog box appears when you try to modify the profile definitions on a computer that is running Commerce Server 2000


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Symptoms

When you try to modify the profile definitions on a computer that is running Microsoft Commerce Server 2000, you experience one of the following symptoms:
  • You receive one of the following error messages:

    Error message 1
    The page cannot be found
    HTTP 404 - File Not found
    Internet Information Services
    Error message 2
    The page cannot be found
    Cannot find server or DNS error
    Internet Explorer
  • A blank Web Page Dialog dialog box appears.
Note In this scenario, you follow these steps to try to modify the profile definitions on a computer that is running Commerce Server 2000:
  1. Start the Commerce Server Manager Microsoft Management Console (MMC) snap-in.
  2. Expand Commerce Server Manager, and then expand Global Resources. Expand Profiles (computername_retail_commerce), expand Profile Catalog, and then expand Profile Definitions.

    Note computername is a placeholder for the name of the computer that is running Commerce Server 2000.

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Cause

This issue occurs because Commerce Server 2000 cannot read the Widgets virtual directory. Commerce Server 2000 cannot read the Widgets virtual directory if one or more of the following conditions are true:
  • The Web site that hosts the Widgets virtual directory is stopped.
  • The Widgets virtual directory does not exist in your Web site.
  • Multiple Commerce Server Solution Sites are unpacked. This issue occurs if the Retail Solution Site is unpacked to a Web site other than the Web site where the original Commerce Server Solution Site was unpacked.
The Profile Definitions node in Commerce Server Manager depends on the Web site where the original Commerce Server Solution Site was unpacked. The Profile Definitions node opens the Widgets virtual directory in this original Web site.

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Resolution

To resolve this issue, use one or more of the following methods depending on your situation.

Method 1: The Web site is stopped

If the Web site that hosts the Widgets virtual directory is stopped, restart it. To do this, follow these steps:
  1. Start the Microsoft Internet Information Services (IIS) Internet Services Manager MMC snap-in.
  2. Expand *computername, right-click the Web site that hosts the Widgets virtual directory, and then click Start.

Method 2: The Widgets virtual directory does not exist

If the Widgets virtual directory does not exist in your Web site, create the Widgets virtual directory. To do this, follow these steps:
  1. Start Internet Services Manager.
  2. Expand *computername, right-click the Web site that you want to create the Widgets virtual directory in, point to New, and then click Virtual Directory.
  3. In the Virtual Directory Creation Wizard, click Next.
  4. In the Alias box, type widgets, and then click Next.
  5. In the Directory box, type c:\program files\microsoft commerce server\widgets, and then click Next.

    Note If Commerce Server 2000 is installed in a folder other than the default location at C:\Program Files, modify the path that you type in the Directory box accordingly.
  6. On the Access Permissions page, do not change the default check boxes that are selected. Click Next, and then click Finish.

Method 3: The Commerce Server Solution Site is unpacked to a different Web site

If the Retail Solution Site is unpacked to a Web site other than the Web site where the original Commerce Server Solution Site was unpacked, use the following method to resolve this issue.

Note For information about how to work around this issue in this scenario, see the "Workaround" section.

Move all the profile definitions to an alternative Web site that you want to use. If you want to manage profile definitions by using a Web site other than the Web site where you unpacked the original Commerce Server Solution Site, modify the BizDeskHost attribute in Microsoft Commerce Server Business Desk (BizDesk) to indicate the Web site that you want to use as the source for the HTML components to use with the Profile Designer. For additional information about how to modify the BizDeskHost attribute in Commerce Server 2000, click the following article number to view the article in the Microsoft Knowledge Base:
811511� How to use the BizDeskHost attribute in the Profile Designer of Commerce Server Manager

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Workaround

If the Retail Solution Site is unpacked to a Web site other than the Web site where the original Commerce Server Solution Site was unpacked, you can use the following method to work around this issue.

Use the Retail Business Desk Web page to manage your profile definitions. When you unpack the Retail Business Solution Site, the Retail Business Desk is automatically configured to use the appropriate Web site for that package.

To manage the profile definitions by using the Retail Business Desk Web page, follow these steps:
  1. Start Retail Business Desk (LOCALHOST-portnumber).
  2. Click Users, and then click Profile Designer.
  3. In the Name list, click the item that you want to view or modify, and then click the View icon.

    Note The View icon appears as an open folder in the upper left of the Profiles dialog box.
  4. Modify the properties of the profile definition, and then click Apply. When you are finished modifying this profile definition, click the Close button.

    Note The Close button appears as a left arrow in the upper left of the Profile: profile definition name dialog box.
  5. Click Yes when you are prompted with the following message:
    Save changes before exiting?

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More information

For additional information about support for Commerce Server 2000, visit the following Microsoft Web site:

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Keywords: KB889581, kbprb, kbtshoot

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Article Info
Article ID : 889581
Revision : 3
Created on : 11/16/2007
Published on : 11/16/2007
Exists online : False
Views : 373