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Backfill requests for some public folders are never completed on an Exchange Server 2003 computer


View products that this article applies to.

Symptoms

Backfill requests for some public folders are never completed on a Microsoft Exchange Server 2003 computer. Additionally, the Exchange 2003 computer continues to generate backfill requests. Eventually, the backfill requests may saturate the network.

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Cause

This problem occurs if the local Exchange 2003 computer replica list for a public folder is out of sync with the information that is contained in the remote server rows in the replication state table.

In Exchange 2003, each public folder store maintains a replication state table to track the status of every replica in the store. The replication state table contains a list of replicating servers for each folder in the public folder store. Each row in the replication state table contains the GUID and the replication ID (ReplID) for the server. The local Exchange 2003 computer also maintains a replica list that includes the replicating servers that are known to the local Exchange 2003 computer for each public folder.

In either of the following scenarios, the local Exchange 2003 computer replica list becomes out of sync with the information that is contained in the remote server rows in the replication state table:
  • A non-existent remote server is referenced in the replica list.
  • An existing remote server is not represented in the replica list.
In either scenario, the local Exchange 2003 computer continues to generate backfill requests that are never completed.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, this hotfix requires Exchange Server 2003 Service Pack 1 (SP1). For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, the following Exchange 2003 services are automatically stopped and then restarted when you apply the hotfix:
  • The Microsoft Exchange POP3 service
  • The Microsoft Exchange Event service
  • The Microsoft Exchange IMAP4 service
  • The Microsoft Exchange Information Store service

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
     Date        Time    Version       Size        File name
   -----------------------------------------------------------
   13-Jan-2005   03:44   6.5.7232.68     295,936   Isinteg.exe      
   13-Jan-2005   03:57   6.5.7232.68   3,261,952   Mdbmsg.dll       
   08-Oct-2004   02:12                     3,304   Redir.asp
   13-Jan-2005   04:31   6.5.7232.68   5,166,080   Store.exe           

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

After you apply this hotfix, run the updated isinteg command. This command cleans up any replica lists that are out of sync and removes any unreferenced remote server rows from the replication state table. To run the updated isinteg command, follow these steps:
  1. Take the public folder store that is generating the backfill requests offline. To do this, follow these steps:
    1. Start Exchange System Manager. To do this, click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
    2. If the Display administrative groups option is turned on, expand Administrative Groups, and then expand your_administrative_group_name.
    3. Expand Servers, expand your_server_name, and then expand your_storage_group_name.

      Note The your_storage_group_name placeholder represents the storage group that contains the public folder store that you want to take offline.
    4. Right-click Public Folder Store, and then click Dismount Store.
    5. Click Yes when you are prompted to continue.
  2. Click Start, click Run, type cmd, and then click OK.
  3. At the command prompt, move to the following folder:
    Drive:\ProgramFiles\Exchsrvr\Bin
    Note The Drive placeholder represents the drive on which you installed the Exchange 2003 program files.
  4. Type the following command, and then press ENTER:
    isinteg -s server_name -test replstate
    Note The server_name placeholder represents the name of the Exchange 2003 computer.
  5. Type the number of the public folder store database that you took offline in step 1. Then, press ENTER.
  6. Type y to continue, and then press ENTER.
  7. In the Isinteg log file, verify that you receive one or more instances of the following error message:
    Replication state table has a row with no corresponding entry in the replica list.
    Note By default, the Isinteg log file for the public folder store is named Isinteg.pub. Isinteg.pub is located in the Mdbdata folder. You can view the file contents by using a program such as Notepad.
  8. Type the following command, and then press ENTER:
    isinteg -s server_name -test replstate -fix
  9. Type the number of the public folder store database that you took offline in step 1. Then, press ENTER.
  10. Type y to continue, and then press ENTER.
  11. In the Isinteg log file, verify that the number of errors that are reported equals the number of fixes that are reported.
For more information about the Isinteg utility, click the following article numbers to view the articles in the Microsoft Knowledge Base:
182081 Description of the Isinteg utility
301460 Exchange command-line parameters for the Isinteg.exe tool
For more information about how to troubleshoot public folder replication problems, click the following article number to view the article in the Microsoft Knowledge Base:
842273 How to troubleshoot public folder replication problems in Exchange 2000 Server and in Exchange Server 2003
For more information about a hotfix for the same problem in Microsoft Exchange 2000 Server, click the following article number to view the article in the Microsoft Knowledge Base:
892485 Backfill requests for some public folders are never completed on the Exchange 2000 Server or Exchange Server 2003 computer

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Keywords: KB889331, kbexchange2003presp1fix, kbbug, kbfix, kbacenter2000, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 889331
Revision : 4
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 335