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You receive "Invalid Parameter (0x80041008)" error messages in the Microsoft Operations Manager Operator Console


View products that this article applies to.

Symptoms

When you use Microsoft Operations Manager (MOM) 2000 or MOM 2005 to monitor a Microsoft Windows 2000-based or Microsoft Windows Server 2003-based domain controller that has the MOM Active Directory Management Pack installed, the MOM Replication health monitoring may fail. When this problem occurs, the Windows Server 2003-based domain controller reports an error event back to the MOM Management Server, and the following events appear in the Alerts pane of the MOM Operations Console:
The script �AD Replication monitoring� encountered a runtime error. Failed to determine whether the WMI replication provider is installed. The error returned was: �Invalid Parameter� (0x80041008)
AD Remote Topology Discovery cannot determine whether the WMI Replication Provider is installed. The error returned was: �Invalid Parameter� (0x80041008).

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Cause

This problem occurs when the Replprov.dll file tries to access a pointer that is not valid. The Replprov.dll file is used by the MOM Active Directory Management Pack to retrieve Active Directory replication-related information, including replication status. When this problem occurs, the Replprov.dll file cannot determine the replication status of the domain controller, and the error messages are generated.

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Resolution

Windows Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

IA-64
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Oct-2004  00:15  5.2.3790.228      108,032  Replprov.dll     IA-64


x86
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   28-Oct-2004  23:13  5.2.3790.228       47,104  Replprov.dll      

Hotfix installation instructions

  1. Create a shared folder in a location that is available to the domain controllers in your domain.
  2. Copy the WindowsServer2003-KB889054-Platform-enu.exe hotfix file to the new shared folder.
  3. Use an account that has administrative credentials to log on to each domain controller that has the MOM Active Directory Management Pack installed.
  4. Connect to the shared folder that contains the hotfix, double-click the WindowsServer2003-KB889054-Platform-enu.exe hotfix file, and then follow the instructions in the wizard.
  5. Repeat these steps on all Windows Server 2003-based domain controllers that are in your domain and that are monitored by MOM.

Windows 2000 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Jul-2005  19:04  5.2.3790.1830      56,544  Replprov.dll     
   22-Feb-2003  02:48                     14,206  Replprov.mof

Hotfix installation instructions

  1. Create a shared folder in a location that is available to the domain controllers in your domain.
  2. Copy the ReplProv.msi hotfix file to the new shared folder.
  3. Use an account that has administrative credentials to log on to each domain controller that has the MOM Active Directory Management Pack installed.
  4. Connect to the shared folder that contains the hotfix, double-click the ReplProv.msi hotfix file, and then follow the instructions in the wizard.
  5. Run the following command at the command prompt after you install the ReplProv.msi hotfix file:
    rundll32.exe %systemroot%\system32\replprov.dll,DoMofComp
  6. Repeat these steps on all Windows 2000-based domain controllers that are in your domain and that are monitored by MOM.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbwinserv2003presp1fix, kbbug, kbfix, KB889054

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Article Info
Article ID : 889054
Revision : 12
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 607