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A cluster node may crash when you manage a server cluster by using certain Symantec storage products in Windows Server 2003 or in Windows 2000 Server


View products that this article applies to.

Symptoms

You are managing a Microsoft Windows Server 2003-based server cluster or a Microsoft Windows 2000-based server cluster by using certain storage products from Symantec, such as the Symantec V2i Protector or Symantec LiveState Recovery products. When you perform certain hard disk operations, the cluster node may crash.

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Cause

This problem occurs because the Microsoft cluster driver (Clusdisk.sys) assumes that it is the top-most driver on the device stack. The Clusdisk driver does not consider that another filter driver might be higher on the device stack.

The Clusdisk driver is an upper-level storage filter driver. The driver attaches to the disk device stack by using a method that is known as "legacy attach." This means that the Clusdisk driver attaches to the device stack after all the Plug and Play filter drivers have attached to the device stack. Therefore, the Clusdisk driver is typically at the top of the device stack.

However, another driver may also use the legacy attach method to attach to the device stack. If this other driver's handler is called after the Clusdisk driver attaches to the device stack, the other driver will be attached at the top of the device stack. When another driver is actually at the top of the device stack, the Clusdisk driver incorrectly overwrites that other device's extension. In this case, one of the following conditions occurs:
That overwritten device extension becomes corrupted.
The computer stops responding and generates a Stop error.

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Resolution

Windows Server 2003

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest Windows Server 2003 service pack

Windows 2000

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required to install this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   28-Oct-2004  10:48  5.0.2195.6994      75,664  Clusdisk.sys

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
824684 Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

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Keywords: kbbug, kbfilesystems, kbqfe, kbclustering, kbdiskmemory, kbwin2000presp5fix, kbhotfixserver, kbfix, KB888607

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Article Info
Article ID : 888607
Revision : 6
Created on : 10/26/2006
Published on : 10/26/2006
Exists online : False
Views : 249