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You experience connectivity issues when you run a program that accesses data on a computer that is running Windows Server 2003 or Windows XP


View products that this article applies to.

Symptoms

When you run a program that performs byte-range locking operations and that accesses data on a computer that is running Microsoft Windows Server 2003 or Microsoft Windows XP, you experience connectivity issues. This problem occurs when you map a network drive to a shared folder on the server and then run the program. For example, the connection unexpectedly ends, or you cannot connect to the server. You may receive an error message that is similar to the following:
Error 64: The specified network name is no longer available.
The error message may vary depending on the program.

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Cause

This problem occurs when a blank Server Message Block (SMB) packet is sent to the server from a client after the client resubmits the SMB packet to the server.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you install this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, 32-bit versions

Date         Time   Version        Size    File name
-----------------------------------------------------
18-Nov-2004  20:22  5.2.3790.233  395,264  Mrxsmb.sys
18-Nov-2004  20:22  5.2.3790.233  158,208  Rdbss.sys

Windows Server 2003, 64-Bit Enterprise Edition

Date         Time   Version          Size    File name   Platform
-----------------------------------------------------------------
18-Nov-2004  20:22  5.2.3790.233  1,123,328  Mrxsmb.sys   IA-64
18-Nov-2004  20:22  5.2.3790.233    464,896  Rdbss.sys    IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For additional information about how to resolve this issue in Microsoft Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:
839027 Programs may fail when they access data on a computer that is running Windows Server 2003 or Windows XP
For additional information about the terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB888319, kbqfe, kbhotfixserver, kbwinserv2003presp1fix, kbfix, kbbug, kbautohotfix

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Article Info
Article ID : 888319
Revision : 12
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 299